Author Topic: Bloom and Glare - black with NaN pixels  (Read 5391 times)

2016-11-08, 11:23:57

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
So I may have a scene that I'm using for testing that seems to render NaN pixels occasionally. Bloom and Glare will turn completely black even if only one NaN pixel is present in the VFB.

Where/how to upload?




2016-11-08, 11:33:12
Reply #1

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 4898
  • Let's move this topic, shall we?
    • View Profile
    • My Models

2016-11-08, 12:42:10
Reply #2

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
Scene uploaded to Dropbox since filesize exceeded 256 MB, filename is 'Coron_1.5.1_Office_Night.rar'... forgot an 'a' there.

There were several issues with the file, including reproducible crashes:

- Scene uses LightMtl as the sole lighting source.
- DR is enabled, 4 DR nodes were used.
- One DR node threw out the 'fault tolerant heap' error. This was on a machine with more than enough RAM which typically chews through everything I throw at it. Disabled FTH globally on this machine, it rendered fine after that. RAM usage in this scene is around 10GB, the node has 64GB.
- The scene produces Nan pixels somewhere at pass 300, from my test it is reproducible but you need to let the render go on for a while. Denoiser will produce that square artifact, Bloom and Glare will turn the image pitch black.
- Crash to desktop while zooming in in the VFB in order to see the NaN pixels and while using RMB to inspect the values of these pixels.
- Crash to desktop upon cancelling the render, seems to be reproducible, happened 2 times. The crash occurs a while after Corona collects data from DR nodes.

Never had any crashes when rendering on a single machine. NaN pixels occured in the past regardless of DR or single machine rendering.

Hope you'll be able to track down the issues, contact me if you need more info or anything else: mg[at]mswee.net or through PM here.

2016-11-08, 14:22:35
Reply #3

Ryuu

  • Corona Team
  • Active Users
  • ****
  • Posts: 488
    • View Profile

2016-11-08, 14:25:31
Reply #4

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
Is it similar to this problem? https://corona-renderer.com/forum/index.php/topic,13812.0.html

Anyway, Ondra is already investigating the NaN issue.
I don't think so, as far as I can tell B&G will produce a black image with NaNs. Then again, my knowledge of the internals is limited...

2016-11-09, 12:08:25
Reply #5

Ondra

  • Administrator
  • Active Users
  • *****
  • Posts: 8739
  • Turning coffee to features since 2009
    • View Profile
Should be fixed, try the next daily when it is out
Rendering is magic.
Private scene uploader | How to get minidumps for crashed/frozen 3ds Max | Sorry for short replies, brief responses = more time to develop Corona ;)

2016-11-09, 12:12:24
Reply #6

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile

2016-11-15, 14:53:30
Reply #7

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
Is this fixed in 1.5. hotfix 2 or only in new dailies?

2016-11-15, 14:54:55
Reply #8

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 7865
  • Marcin
    • View Profile
I believe it's the next daily, but it probably won't hurt to test hotfix 2 too. :)

2016-11-15, 14:59:28
Reply #9

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
I'm asking because the fixes for hotfix 2 looked like they were exactly the issues I have posted above. If they're not there's no point in testing, if they are I would test to confirm.

2016-11-15, 15:05:37
Reply #10

Ondra

  • Administrator
  • Active Users
  • *****
  • Posts: 8739
  • Turning coffee to features since 2009
    • View Profile
this fix was actually simple enough to do it in hotfix 2, so go ahead and test it! ;)
Rendering is magic.
Private scene uploader | How to get minidumps for crashed/frozen 3ds Max | Sorry for short replies, brief responses = more time to develop Corona ;)

2016-11-18, 15:33:59
Reply #11

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
So, just tested with 1.5.2 and unfortunately I'm getting exactly the same problem - NaN pixel(s) > Bloom&Glare black result. It didn't crash yet when collecting data from DR servers but it didn't crash every time back then so chances are it still may crash, only not regularly.

Ondra, in the scene I sent you the NaN pixels will always appear on that picture on the wall. It's either the glass or the object behind or a combination of both that will produce them.

2016-11-22, 00:36:46
Reply #12

Ondra

  • Administrator
  • Active Users
  • *****
  • Posts: 8739
  • Turning coffee to features since 2009
    • View Profile
ok, this was actually a separate bug with exactly the same result. I fixed this one as well
Rendering is magic.
Private scene uploader | How to get minidumps for crashed/frozen 3ds Max | Sorry for short replies, brief responses = more time to develop Corona ;)

2016-11-22, 13:27:28
Reply #13

pokoy

  • Active Users
  • **
  • Posts: 1178
    • View Profile
Great, thanks! Will the fix be in the next daily? I would test again just to be sure...

2016-11-22, 15:35:07
Reply #14

Ondra

  • Administrator
  • Active Users
  • *****
  • Posts: 8739
  • Turning coffee to features since 2009
    • View Profile
yes, but the daily will be after corona academy... contact me on skype to get the build sooner
Rendering is magic.
Private scene uploader | How to get minidumps for crashed/frozen 3ds Max | Sorry for short replies, brief responses = more time to develop Corona ;)