Corona Renderer Forum

General Category => Bug Reporting => Topic started by: Jpjapers on 2018-07-10, 16:36:59

Title: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-10, 16:36:59
I have a thread on mantis about the excessive noise in some scenes and ive traced the issue back.

If i create a lightsource the same size as a real world LED module (Roughly 25mm dia) and set the real world lumens output (12000lm) in lightmix its incredibly dim and needs boosting to 10,000 lightmix intensity before it shows correctly and this in turn generates insane noise.
I built a spotlight to manufacturer spec and fitted this in my renders and even after running for 17+ hours on multiple DR nodes and going through denoising, it was still horribly noisy.

As soon as i switch back to W/m2 the noise is normal again.

I have a thread on mantis for this but Ive tried both dropbox and the private scene uploader and havent managed to upload a 160mb archive to either. It crashes every time.
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: maru on 2018-07-16, 15:02:33
Interesting, but we would need the scene and solid reproduction steps to understand it. Can you try putting it on your Dropbox, Google Drive or any other hosting, and sending us the link?
Also, is the noise visible ONLY in the LightMix after cranking up the intensity, or also in the original beauty pass? Persistent noise is expected when increasing intensity in LightMix too much, but it should not be dependent on the light intensity units anyway.
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: cecofuli on 2018-07-16, 17:00:24
We know that there is a but in CoronaIES light about intensity value.
But, often, the noise created by the IES lights depends also from a .ies file.
Also, more "direct" is the light from IES, more noise it will produce.

Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-16, 19:50:28
Interesting, but we would need the scene and solid reproduction steps to understand it. Can you try putting it on your Dropbox, Google Drive or any other hosting, and sending us the link?
Also, is the noise visible ONLY in the LightMix after cranking up the intensity, or also in the original beauty pass? Persistent noise is expected when increasing intensity in LightMix too much, but it should not be dependent on the light intensity units anyway.

Hey maru,

Yeah so on the mantis ive been told its been reproduced with the first scene i sent. I can put the second on google drive if you guys still want to see it.
The noise begins developing in lightmix after a while. I noticed it after about 40 passes or so starting to generate fireflies and then at 140 passes it was really bad in the 'hotspot' areas.  I havent checked the beauty pass as well as lightmix so ill do that tomorrow. Problem with the intensity is that it should be fine at 2000lm and lightmix set to 1 as it is exactly to the manufacturer spec however i had to crank it wayyyy up to get any visibility at all.
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-16, 20:16:24
I cant replicate the light units issue but in this scene the fireflies get progressively worse as the render goes on and don't ever seem to clean up.
Ive attached the scene here.
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: cecofuli on 2018-07-16, 22:54:55
Can you remove the lamp model? Maybe it's a problem of the CoronaIES inside the model (chrome material?) and it creates "caustics".
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-16, 23:11:37
Can you remove the lamp model? Maybe it's a problem of the CoronaIES inside the model (chrome material?) and it creates "caustics".

I dont have an IES enabled for the light
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: maru on 2018-07-17, 11:06:17
This is the mantis report, right? https://corona-renderer.com/bugs/view.php?id=3038
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-17, 11:33:24
This is the mantis report, right? https://corona-renderer.com/bugs/view.php?id=3038

That is correct
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: maru on 2018-07-24, 15:04:09
to self: asked QA if additional report needed
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-31, 12:46:27
to self: asked QA if additional report needed

Has anyone figured out the source/ a workaround?
Its a live project and im struggling to figure out how to make the spotlighting work without creating this noise issue.
I tried increasing the light intsneity instead of increasing in lightmix but it didnt change anything and i have to crank it to some crazy intensity to match real world light levels from a luminaire that size
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Papuca3D on 2018-07-31, 14:25:14
Answered on Mantis.
Title: Re: Excessive noise that never clears when using lumens as intensity.
Post by: Jpjapers on 2018-07-31, 16:31:06
Answered on Mantis.

Thanks :) New to the team?