Corona Renderer Forum

General Category => General CG discussion => Hardware => Topic started by: JOZU on 2018-12-18, 20:51:21

Title: threadripper 1950x issue while rendering
Post by: JOZU on 2018-12-18, 20:51:21
Hi all,
Im facing some problems most propably becouse of threadripper 1950x..
I bought new processor threadripper 1950x, new motherboard MSI and 64GB of RAM. When Im rendering in corona it happens that my screen goes black, but system is still running, so I have to restart my computer. It happens unpredictably. Sometime I can render during whole night and nothing happens. But after I save my final image and want to render another scene the screen goes black after 10 minutes or 2 hours or so. I tried reinstall my system two times, I also tried change RAM from my 64GB to new 16GB but it is still happening. I tried all HW tests for RAM, graphic card and processor all sucsesfull without any warning. I tried render my old scenes which I renderer out successfully on my older maschine. The system is running normaly when doing common work, searching thru internet, using photoshop or indesign. It only happens when using corona. My scenes are packed and placed on one place disc C SSD (I tried aslo another disc D SSD) so there cant be issue with missing textures. Im using Cinema R17. I wrote on Cinema bug thread and got answer it could be becouse of bloom and glare are switched on while rendering but that is not the problem. Thomas M. Grimes recommended me to write here on general discussion for some help. Is there anybody who could advice me. Do you think it could be bad motherboard or even processor? although I tried test it out sucsessfully. Those poeple from the company i bought those three components cant racionally help me becouse they dont test computers for rendering and certainly not for using corona. Im convinced that it must be becouse of one of those three components I bought it. it is not becouse of RAM I tried new ones, could it be the motherboard? if processor is without warrnings after load test. If there is anybody to tell me something I will be glad for your words.
Title: Re: threadripper 1950x issue while rendering
Post by: TomG on 2018-12-18, 22:46:38
One new thought on reading it here - you mention the screen goes black, so there's not an actual crash or blue screen. So that now makes me wonder if it is a graphics card issue - could the card get too hot with the processor running full speed during rendering? Anything in the Windows log to suggest what may have failed? One last thought, if this is a recent thing, are you using the NVIDIA AI denoising, which is in the latest daily build from Dec 14th, and if so does disabling it make any difference?
Title: Re: threadripper 1950x issue while rendering
Post by: Vuk on 2018-12-18, 23:14:58
Hi Josef I understand you are frustrated but before you jump to conclusions lets rule out some things. Also you mentioned that you bought new cpu and motherboard but the other parts are also new or used? If you give a more detailed brake down of your system and parts I am sure we will be able to help you with more sucess.

Here are my toughts:

1) You mention you ran stress tests on your pc? Which tests did you run? Did you run them only once, a few times and determined that the pc is stable? If you haven’t let them run for a longer period and check if there is any issue. Also check termals during this tests and voltage. Have you overclocked the system?

2) When screen goes black does the keyboard num lock react when you press it, also on the motherboard do you have an error code displayed in red? If so check your manual.

3) When screen is black do you see entering power save mode displayed. This issue can usually be related to graphics card or bad power cable or even a bad monitor. Make sure to try to recrate the black screen issue with another monitor. Before doing so try another port on your gpu like hdmi or displayport or dvi.

4) Enable high performance mode in win 10 and disable sleep. Check your usb slots where the keyboard and mouse and other devices are pluged. On some x399 boards and generaly on some ryzen boards some usb slots are BIOS flesh specific and can bug the system. You can check that in the motherboard manual also. Make sure to have the least possible clutter of usb plugs. So just have the keyboard and mouse pluged. Only the essentials and re-run the tests/renders.

5) Be sure to check under windows system settings you have the exact amount of ram you put in the machine. Finally perform a mem test from bios with mem test program you can download from internet for free.

6) Finally it can be PSU related. Are you pluged to the wall directly or to an multi-outlet? Try pluging the system alone to a single wall outlet. I doubt its the motherboard since bad mobos manifest their problems right away as do cpus... I had a bad mobo once couldn’t even boot the system...

7) Check your bios version. If its something very old go to the official page of the MSI board and under support download the latest drivers and update the BIOS. Some BIOS revions tend to solve memory compatability issues.

Title: Re: threadripper 1950x issue while rendering
Post by: Vuk on 2018-12-18, 23:39:15
If you are really worried about the cpu you can only inspect if it has some phisical damage like damaged capcitators on the back side but in that case it wouldn’t boot at all. I am pretty sure its not cpu related since cpu’s are pretty much the most durable component. Same goes for the motherboard. A damaged motherboard in most cases won’t boot, you can inspect that as well to see if you find something strange like bended pins or something else. I think this is more of a power/electricity related issue and monitor, power cables, graphics card could be the source of your problem. If you are using an old psu I would start with that first also.
Title: Re: threadripper 1950x issue while rendering
Post by: danio1011 on 2018-12-19, 01:36:27
Check your event logs (Start > Run > Event Viewer) to see if that gives you any clue.  My guess is it's your power supply since your graphics card isn't under any load (assuming you're not using Optix for final, overnight renders?)

Also you could try disabling all power saving things like shutting off the screen, etc.
Title: Re: threadripper 1950x issue while rendering
Post by: JOZU on 2018-12-19, 02:42:28
Thanks for your reply! I really appreciate it!
This issue is not graphics card. My graphics card (although it is dig girl gtx 680 4GB) is in good condition. I tried aslo another GPU so Im pretty sure it is not GPU problem. It was the first thought
 I got too. But anyway thanks for your reply again!

Your are the gold boy! Thanks!!! Im too exhausted to reply for your recommendations, but you most propably hit the jackpot! I will surely reply, explain my inclination to your reply tomorow. I was waiting for final image for an about 5 hours till now with lights switched off in my whole flat (got home office).  You can imagine where is the problem. MAYBE. After three week of frustration I maybe got the solution. And you assured me in that! Even though I got it when I wrote to this forum, beforu your reply. Explain it tomorow. THANKS!!!

Thank you!!!! you are maybe so close!!! I will try to describe it tomorow Im done.
Title: Re: threadripper 1950x issue while rendering
Post by: jamesdowling on 2018-12-19, 15:29:11
Which MSI board do you have? I had the same problem with my msi meg x399 creation where it would just black screen, although the pc would still be running (fans, led's etc) I couldnt get it to wake up. It ended up being a dodgy bios for that board so I would check that first as it solved my problems.

If you have the meg creation there is a forum post with beta bios, im using E7B92AMS.127 which is stable for me .129 was not stable.

Title: Re: threadripper 1950x issue while rendering
Post by: JOZU on 2018-12-19, 20:05:22
Hi James, finally someone who got the same problem. Believe me I dont like it.
From yeasterday I managed to finish two visuals, each one cooked about 6 hours, without this black screen problem. Firstly I thought it was becouse of unstable electric circuit in my flat. But today I tested it and it seems to be not the problem. Anyway I finished two images and today I worked mainly on modeling, Im going to let corona run over night for another image. Im in press from client. I have to handle out 16 visuals till 9.1. So You can imagine how I got nervous. Yet I spent those money so I was really in bad condition. But from now it seems good.

Im not computer expert although I work in this field for about 8 years. I attended art school so Im focusing maily on esthetics and design and all those computer matters I always left on computer service. So If the problem will appear it is surely the same thing as you got. But I cant operate with bios, so will most propably tell this to the service guys, when claim those components. But till 9.1. I need to finish those images. I hope there wont be problem and if will, I will got mad. But today I wrote to some render farms to help me so this could be aslo solution.

Are there any instructions how to install E7B92AMS.127 ( I dont even know what is it, is it driver?) I would do it by myself if it is not some very complicated operation...I do not want too much to talk to those service guys. They are fine, but I have there my maschine two times and it is always frustrating talk with them about problem I dont know. They dont use corona so they can understand this specific problem neither. They solve it as ordinary reclamation. And it would take too much time, chrismas etc. Anyway this time I could tell them exactly what you suggested to me. But if it is not complicated and exist some instruction somewhere I would try it to myself. I have got X399 SLI PLUS.

Could you just tell me how coplicated is to instal E7B92AMS.127 to bios? : ) : )

Anyway I will render during the night and will hope not to see black screen in the morning.

Now I read your post about your black screen problem and it seems that is is different. Becouse I have this issue only when Im wrote that it happens when you are using 3D max, modeling etc.
We have one common thing...hard restard...I always use power supplier to restart my comp. Do you think I should go for the hard restart button on the motherboar as you?

You see Im not into computers.

Title: Re: threadripper 1950x issue while rendering
Post by: TomG on 2018-12-19, 23:24:29
The motherboard manufacturer site should have instructions for installing a new BIOS. This will vary depending on the motherboard manufacturer - some have a handy Windows application that will do it for you, some need you to place the bios on a bootable USB stick and run a command, and so on. Generally it's not too hard and there should be a step by step on their website - be sure to read and understand it all first, maybe print it out (or pull it up on another computer), because it will not be pleasant if the steps aren't followed and you'll end up with that computer not being bootable.
Title: Re: threadripper 1950x issue while rendering
Post by: jamesdowling on 2018-12-20, 10:37:28
No problem JOZU.

That bios version is specific to the msi meg x399 creation so it wont work with your motherboard (I just said it on the off chance you had it)

My pc crashed out when rendering as well so I would check the bios first as thats the easiest thing to change. From my experience with my 2990wx build all the problems I have had is with the motherboard BIOS.

If you go to that page in the bios tab you can download the latest Bios version from there (7B09vA7)

Above that there is a youtube link to a video that explains how to do it (

Basically you put the file on a usb flash drive, restart the pc and hold DEL to go into the bios and then theres an option to load the new one in. It wont affect any files/programs you have installed and takes about 5 minutes.

If that doesnt work then you can start looking for a defective part.
Title: Re: threadripper 1950x issue while rendering
Post by: JOZU on 2018-12-20, 12:45:08
Thanks for your support! I really apreciate it. It seems that i can hadle it. Thanks!

Thanks a lot for your reply! I wanted to ask if there is some youtube insrtruction video, but was too shy. So you read my thoughts! I have to ask you one more question is there way how to check if this BIOS version is already installed on my maschine?. If so I dont see the reason why to instal it over again or do you think it could help? to reinstall the same version.

And one more question what did you mean by ... looking for a defective part. Is it some Bios work too?

Anyway tonight I managed another final render. It cooked about 6 hours 3500x2400. So My morning was merciful. I exchanged electric plug. So I still hope it is becouse of unstable electric current as Vuk wrote me. Actually He described all possible options how to fix that. He aslo mentioned bios version update. I will surely answer him after this will be the past.
I discovered that electricity issue when I was makeing coffee in the kitchen. One time I just hit the rendr button and went to the kitchen to make coffee and when I went to my office room the screen was black. It happened one more time...And that time I was telling myself, damn I will make coffee hope that wont be black screen - it was just joke in me mind, but it happened!!!! I thought I got mad, but after some time I realized it can be bad electricity curcuit. And in the same time Vok wrote about PSU and plugging to the wall directly or to an multi-outlet. It is either bad el circuit or bad multi-outlet, bud when I tested it...I didnt find the answer. But still hope it is this problem since I exchanged electric plug and it didnt happend. I live aslo in new house, with new electro installation so Im still in doubts, But who knows? If it will happen again I will go after to update/reinstall the bios version.

So those are my problems. It took 3 weeks already, I think there were two problems. One was with bad RAM (when I bougth those three new componets there were two strange things one was black screen during rendrering THE PROBLEM and second was stroke-death mouse and complete restart during common thing as work in Indesign, photoshop, searching net. I know this was the RAM issue, couse it happened me few year ago, so I changed RAM and hoped that was all the poblem but after this screen went black again so I knew it was not complete solution but it never happened with stroke-death mouse and complete restart this I solved out by exchanging new RAM and the second problem is either bad el circuit or bad multi-outlet, or bad Bios. I have to find it out. But now I have to render another 10 visuals 3500x2400 and hope it will be stable untill I finish this commission. After that it can be easily black screen every minute, Now I already know few solutions!!!
My designs are already approved so now Im fucusing only on rendering. I already got older after those 3weeks but thaks to you guys Im not mad.
Title: Re: threadripper 1950x issue while rendering
Post by: jamesdowling on 2018-12-20, 14:51:36
If you restart your pc and hold down DEL before windows starts it will take you to the bios, somewhere at the top its should say what bios version your running. If its the same as the latest one on the website then you dont need to install it.

Sorry I meant if your running the lastest bios and it is still crashing then it might be a part that is faulty (ram,gpu etc)
Title: Re: threadripper 1950x issue while rendering
Post by: JOZU on 2018-12-21, 23:01:10
Hi James,
Tonight I managed to finish one another final render. But from the morning I was facing two anothere black screen issue, each one after 5 hours of rendering. I decided to reinstall Bios version as you mentioned. There was older version A60. So before a while I managed to instal the latest version A70. I hope this was the problem, becouse my guess about bad electrocity would be really odd. I will render over night and see if this is it. Surely I have to render all christmas to see if that was the problem, becouse with A60 I could render 3 days and nothing happened. So I will see. I just want to write my progress.
Title: Re: threadripper 1950x issue while rendering
Post by: micmac on 2019-07-17, 12:20:38
Hello Jozu,
Do u find out the problem with black screen?
I have the same error... after 15 minutes of rendering, screen turn black and i have to reset the computer...

my spec are:
_AMD 2990WX
_G.skill aegis DDR4 8x16 GB 3000Mhz CAS 16
_Corsair hydro series H80i V2
_Gforce RTX 2070 Twin
_Samsung series 860 EVO 500Go
_Windows 10 (Family)

Title: Re: threadripper 1950x issue while rendering
Post by: JoeVallard on 2019-07-18, 02:50:36
my spec are:
_AMD 2990WX
_Corsair hydro series H80i V2

I could easily be wrong but I think the H80i doesn't cover most the cpu and the 2990wx needs some good cooling. Maybe Juraj will check this but I think he mentioned the enermax liqtech is the Watercooler that fits specifically to the tr4 socket.
Title: Re: threadripper 1950x issue while rendering
Post by: micmac on 2019-07-18, 12:19:14
Hello Joe,
thx for answering.
Juraj, can u confirm this? Is it possible to have black screen due to a overheat? When it crash processor (2990wx) is at 68C° (coretemp software).
Title: Re: threadripper 1950x issue while rendering
Post by: Juraj Talcik on 2019-07-19, 16:23:07
Hello Jozu,
Do u find out the problem with black screen?
I have the same error... after 15 minutes of rendering, screen turn black and i have to reset the computer...

my spec are:
_AMD 2990WX
_G.skill aegis DDR4 8x16 GB 3000Mhz CAS 16
_Corsair hydro series H80i V2

Yeah the problem is this whole build. There is one medium and one huge problem.

Small: X399 SLI PLUS. This is not a board for 2990WX due to insufficient VRM. Important thing with VRM is that it accounts for CPU and Memory. 250W CPU is already super hungry, but 8x16GB 3000 & C16 is equally so, that puts tremendous stress on the memory controller.
There is reason why MSI MEG has 19 phases (16 for CPU and 3 for Memory).

Yeah some people use poor boards for 2990WX as long as you have very good case airflow but I don't think those people run 128GB& 3000& CL16 memory.

The biggest problem: H80 V2. Not only is this tiny cooler that cannot cool 250W of heat, it doesn't even cover the Threadripper heatsink. There is only one rule to follow with TR4 platform, and that is to buy dedicated TR4 coolers.  I.e Noctua UH14-S or Enermax Liqtech 360 II TR4.

Buy MSI MEG or ASUS ZENITH ALPHA and either UH14-S or Liqtech 360 II.
Title: Re: threadripper 1950x issue while rendering
Post by: micmac on 2019-07-23, 11:53:51
Thx Juraj for answering!
Title: Re: threadripper 1950x issue while rendering
Post by: polysmooth on 2019-07-23, 12:24:27
Hello everyone,

We had the same problem at the company with 2 threadripper 2990WX. black screen, forced to unplug the computer to restart it

A machine with a motherboard: ASUS® ROG STRIX X399-E

A machine with a motherboard: ASUS® PRIME X399-A

there is exactly the same problem with the two motherboards.

the 2 computers are with Noctua NH-U14S TR4-SP3 and  Corsair VENGEANCE DDR4 2400 MHz (4 x 16 Go)

We have solved the problem by modifying the parameters of the ram in the bios of the motherboard.

Here is the link of the tutorial.

My big disappointment with the threadripper is that the cinebench score is good but the rendering with corona is not as fast as with my bixon 2698 V4 ES

bi xeon 2698 V4 ES cinebench: 4200
threadripper 2990WX cinebench: 5000

bi xeon complex corona scene: 1 hour
threadripper 2990WX complex corona scene: 1h50min!

I do not understand where this problem comes from but I find the performance of the threadrippers very random.
Title: Re: threadripper 1950x issue while rendering
Post by: Juraj Talcik on 2019-07-23, 15:38:07
You definitely shouldn't need to modify voltage of memory for 2990WX for it to work. But it's good to have motherboard that has enough VRM capacity for both CPU and Memory controller. MSI MEG has 16 phases for CPU, 3 phases for memory controller.

STRIX and Prime have 8 phases for both (together and they're not exactly big mosfets), they're not motherboards for 2990WX. Nothing to even ponder there.

To get full performance out of 2990WX, you definitely need 2993 MHz memory with fast timing (CL14-16), that's the highest speed 8x16GB modules will run. People with 4x16GB (or 8x8) might be able to get even 3200 MHz stable, but I wouldn't trust it for rendering.
We also use 2698v4 ES Xeon nodes, and the 2990WX does beat it, but yes, not by drastic measure.  Corona is super memory bandwidth dependent and Intel still scores higher there.

Cinebench R20 illustrates this better than R15.

Corona Benchmark for 2x2698v4 ES = 42 seconds
Corona Benchmark for 2990WX @ Stock 3.4 GHz all-core boost @ 2993 MHz memory = 38 seconds
@ Stock 3.4 GHz all-core boost & 2133 MHz memory = 52 seconds (!!)

(Just for comparison, my i9 7980XE 18core @ 4.0 GHz @ 3000 MHz memory is 48 seconds)

The benchmark is not best with the way it starts and does precomp, it is absolutely not linear and it doesn't account for the fact the full Corona will offset AVX clocks.
So 2698v4 ES will run at lower frequency.

So your issue is memory (and motherboard). But current generation Threadripper has definite limitations when it comes to Corona. Let's see what Zen2 Threadrippers (2019 Q4/2020 Q1) will do with the changed architecture.
There are AMD performance profilers for the devs, but I am not sure if there is something they can do.