Corona Renderer Forum

General Category => Bug Reporting => Resolved bugs => Topic started by: loocas on 2015-06-23, 20:51:51

Title: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-23, 20:51:51
Once again, the ever returning bug of ignoring motion from point cached geometry.

This is a standard point cached geom (xml/mc), animation of paper crumpling, that is completely being ignored by Corona.

The white ball there (the smear) is an animated sphere just to make sure motion blur actually works in Corona.

Please, fix this!!! I need MBlur asap!

Corona version: 1.01.00, Maxsdk version: 2014

Build timestamp: Jun 16 2015 16:48:31
Defines: Wide RGB
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-23, 20:56:23
There might be something more to this concrete scene, because it seems that Corona does not ignore point cached geometry at all under certain conditions.

Can anyone confirm this, please? I'll investigate further...
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-23, 20:58:40
Ah, no, my bad, the motion blur IS NOT THERE, it was being created by transformation (atop the point cached geom, I'm animating the object's transform as well), so that is being calculated, but the PT is being IGNORED alltogether. :(
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-23, 21:09:01
Aaaaaaand, Corona hangs when using XMESH.

Great...
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: maru on 2015-06-24, 10:58:28
Seems to work fine here, though I am not sure if I am doing this the same way as you did. Picture and scene in attachment.
Can you try using mesher on the point cached object and see if it gets proper MB?
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-24, 11:05:25
I was told it was because the changing topology of my mesh. Not sure about that, I'd have to double check that as I'm subdividing heavily the mesh based on smoothing groups, dynamically, so that might be the real problem here. Which would be a huge problem for me as I need this "paper like" look.
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: maru on 2015-06-24, 11:18:52
Yeah, if there is changing topology like adding new edges etc, then this could be a problem, I'll try to check it.
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: Ondra on 2015-06-24, 11:26:54
specifically there is changing number of normals
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-24, 11:29:01
specifically there is changing number of normals

Well, this is a huge problem as I specifically need this feature in order to achieve the effect I'm after. :(
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: maru on 2015-06-24, 11:30:49
Hmm how did you do this? When I am trying to save point cache file for object with animation where number of faces changes it says "point count changed while recording" or "cache file is not a valid file".

Tried enabling MB for the geometry with modifiers, got a freeze right now, will try to submit minidump.
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: loocas on 2015-06-24, 11:34:08
Hmm how did you do this? When I am trying to save point cache file for object with animation where number of faces changes it says "point count changed while recording" or "cache file is not a valid file".

Tried enabling MB for the geometry with modifiers, got a freeze right now, will try to submit minidump.

I'm changing the smoothing using the Smooth modifier after the point cache, then I subdivide the mesh based on the resulting smoothing.

I don't know why this is such a problem for corona as the number of verts shouldn't be changing at all.
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: maru on 2015-06-24, 11:46:10
Hmm how did you do this? When I am trying to save point cache file for object with animation where number of faces changes it says "point count changed while recording" or "cache file is not a valid file".

Tried enabling MB for the geometry with modifiers, got a freeze right now, will try to submit minidump.

I'm changing the smoothing using the Smooth modifier after the point cache, then I subdivide the mesh based on the resulting smoothing.

I don't know why this is such a problem for corona as the number of verts shouldn't be changing at all.
Confirmed. Motion blur will not work when using "smooth" modifier if the smoothing will change dynamically. It will work fine if set to 0 or 180 (a value where nothing changes during the animation). Attaching the file if someone wants to take a look. Not sure if fixable.
Title: Re: Corona doesn't render point cached motion blur, again!
Post by: Ondra on 2015-06-24, 11:46:31
The problem is that the normals could still come out garbled. I will try to look to see if there is a way to fix this one, but general fix (for any change) is still far away.