Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - loocas

Pages: [1] 2 3 ... 6
1
Feature requests / Re: Which 3D soft to integrate into next?
« on: 2018-02-15, 18:42:25 »
It's 2018 and to me, personally, the most useful integration would be Corona + Nuke/Nuke Studio

2
I need help / Re: Corona Renderer interfaces inaccessible?
« on: 2016-11-10, 20:25:56 »
Um... anyone? Devs?

3
I need help / Corona Renderer interfaces inaccessible?
« on: 2016-10-26, 10:28:54 »
Hi there,

just a question, I want to quickly access the Corona's VFB, so, I need to reach it via MAXScript.

I found it under interfaces, namely CoronaFp interface, but it seems the interface is inaccessible? How come?

Here's my simple inspection code:

Code: [Select]
getInterfaces renderers.current
#()
showInterfaces renderers.current
  Interface: CoronaFpTest
   Properties:
   Methods:
    <void>dummy()
   Actions:
  Interface: CoronaFp
   Properties:
   Methods:
    <integer>showVfb <boolean>show
    <integer>resumeRender()
    <integer>loadAndResume <string>exrFilename
    <integer>dumpVfb <string>exrFilename
    <integer>parseViewexp_INTERNAL <maxObject>viewExp <maxObject>outCamera
    <integer>setDisplayedChannel <integer>channel
    <value>getVfbContent <integer>channel <boolean>toneMapping <boolean>renderStamp
    <integer>resetSettings()
    <integer>exportScene <string>filename <boolean>renderImmediately
    <string>getCoronaVersion()
    <double>getStatistic <integer>statisticId
    <color by value>getBlackbodyColor <float>temperature
    <integer>loadDrIpFile <string>filename
    <integer>startInteractive()
    <integer>startInteractiveDocked()
    <integer>stopRender()
    <integer>showLicensingPopup()
    <boolean>isRendering()
    <integer>reparseInteractive()
   Actions:
OK

I cannot getInterfaces() on the Corona renderer's object. It shows them, but doesn't return.

Is this a bug? Or a weird feature?

Thanks in advance!

4
well still, same thing applies - the error message is from Corona2014.dlr, there should be no such file if you install the daily build correctly

The name of the plugin in my error picture should be irrelevant. I tried renaming it as suggested by someone here (I doubted you'd reference the assembly by a name, that doesn't make much sense, but still, what if? :) ).

5
Did you delete the Corona2014.dlr and CoronaUtils2014 from the /plugins/ folder? And made sure there were only 2013 versions?

I don't even source the 3ds max plugins folder at startup. I only use my own custom paths.

6
So, what am I supposed to do?

I downloaded the daily build. Copied the 2013 plugins to my custom folder structure for Max, the DLLs that came with the daily build into my DLL repo, where other Corona DLLs reside as well and overwrote those with the same name.

That's it. But then I get this error.

1.4, I installed the very same way and works absolutely fine without any issues.

7
If you doesn't rename the files for the plugin folder, then you're not "copying over". And then you got a mix-error.

I keep the DLLs and the plugin files in separate (versioned) directories which I source on startup. This setup has always worked. Doesn't work now.

8
I did install (deployment copied) 1.4 which works without issues.

The VC redistributables are all installed.

I have a custom plugin structure and I only load what I need, so I don't need to uninstall anything. So far, everything has worked without issues.

copying over the 1.5 daily builds doesn't work, I end up with this exact error.

9
Thank you, but I will be not applying pending windows updates. I'd rather use 3ds Max 8 and Scanline. :)

10
Well, renaming the files does absolutely nothing.

And I'm still getting the start up error.

I used to do this regularly without any issues. Just copy over the dlls and the 2013 plugins and be done with it. But this build is giving me errors.

11
Hi,

when I use the 2013 plugins in Max 2014 I'm getting a "Procedure couldn't be found" error on startup.

Is there anything special needed for Max 2014 to get Corona working? I thought Max 2013 and 2014 shared the same SDK version, no?

Thanks in advance.

12
Hmm how did you do this? When I am trying to save point cache file for object with animation where number of faces changes it says "point count changed while recording" or "cache file is not a valid file".

Tried enabling MB for the geometry with modifiers, got a freeze right now, will try to submit minidump.

I'm changing the smoothing using the Smooth modifier after the point cache, then I subdivide the mesh based on the resulting smoothing.

I don't know why this is such a problem for corona as the number of verts shouldn't be changing at all.

13
specifically there is changing number of normals

Well, this is a huge problem as I specifically need this feature in order to achieve the effect I'm after. :(

14
I was told it was because the changing topology of my mesh. Not sure about that, I'd have to double check that as I'm subdividing heavily the mesh based on smoothing groups, dynamically, so that might be the real problem here. Which would be a huge problem for me as I need this "paper like" look.

15
Aaaaaaand, Corona hangs when using XMESH.

Great...

Pages: [1] 2 3 ... 6