Corona Renderer Forum

General Category => Bug Reporting => Topic started by: alexyork on 2016-05-18, 11:56:55

Title: Render Selected slower than expected
Post by: alexyork on 2016-05-18, 11:56:55
Didn't mean to make that title rhyme, but what can you do? :)

We're having a little trouble with render selected at the minute. With only one very small and fairly simple object in the include list, the render at 1080p still seems to take quite a long time to reach only 50 or so passes - in the region of around 2 minutes. We've noticed that this is helped a lot by using a region around the object, but this isn't practical for animation, which we're doing, since the object is visible across most of the frame, so the region would be the whole frame.

Are we doing something wrong here? Is there a way we can optimise?

Currently using daily build from April 24th. We *could* move to 1.4 for this if it would help?

Cheers,
Title: Re: Render Selected slower than expected
Post by: romullus on 2016-05-18, 12:47:20
I agree with you, render selected and adaptivity combo has some issues. I had reported it twice but it didn't catch developers attention. My reports here: https://corona-renderer.com/bugs/view.php?id=1820 and here: https://corona-renderer.com/forum/index.php/topic,7239.msg75985.html#msg75985

It also was reported by someone else and resolution was, that it is expected: https://corona-renderer.com/bugs/view.php?id=1392

Don't know, but it looks kinda strange to me :/
Title: Re: Render Selected slower than expected
Post by: alexyork on 2016-05-18, 12:54:16
Thanks Romullus. Going to test again now with adaptivity off and see if it helps! At the moment it takes the same amount of time more or less to render 1 object within a scene of hundreds... so it's basically only acting as a cookie-cutter rather than with any kind of speed benefit which you'd naturally expect.
Title: Re: Render Selected slower than expected
Post by: romullus on 2016-05-19, 22:32:08
I'm moving this topic to bug reporting. I really would like to get definitive answer from devs if this is a bug or expected behaviour. It's bugging me out.

I want to believe that this is the last time i try to escalate this "bug?".
Title: Re: Render Selected slower than expected
Post by: alexyork on 2016-05-20, 10:26:58
Turning off adaptivity helped enormously, but it's still painfully slow to use RS on a couple of small objects still. Hope this can be optimised.
Title: Re: Render Selected slower than expected
Post by: Ondra on 2016-08-19, 17:52:30
Is this fixed in 1.4? There was a lot of adaptivity issues fixes, can you try it out if this still happens?
Title: Re: Render Selected slower than expected
Post by: alexyork on 2016-08-22, 11:08:07
Is this fixed in 1.4? There was a lot of adaptivity issues fixes, can you try it out if this still happens?

Hi Ondra,

We'll try to let you know if/when we come across this again.

Cheers,
Title: Re: Render Selected slower than expected
Post by: romullus on 2016-08-22, 15:55:40
Hi Ondra, i've tested it briefly in latest build and it still behaves much like described in this post: https://corona-renderer.com/forum/index.php/topic,7239.msg75985.html#msg75985
Title: Re: Render Selected slower than expected
Post by: alexyork on 2016-09-12, 11:26:56
Hi guys,

We just did a very very simple test here in 1.4 on a live project again and have the same results as in 1.3. In this test, using only the Corona Region resulted in double the rendertime compared to the same region using Max Region. Using Max Region with Corona Region didn't seem to affect anything. This is using Adaptivity and no DR, by the way.

Hope this can be optimised.

Cheers,