Corona Renderer Forum

Corona Renderer for Cinema 4D => Bug Reporting Cinema 4D => Topic started by: niedzviad on 2019-02-11, 09:44:37

Title: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-11, 09:44:37
Hi, I need help. I have a problem with one scene. It is saving with black beauty pass, all passes are there. https://imgur.com/a/RAP3UUR
 I've rendered this scene 3 times, 3 times bug appears.
What I tried to do.

During rendering I see the beauty and I can save it...

The scene was created on beta, and finished at commercial version.

Can I composite the beauty using the direct, indirect etc.?

Gear: Windows 7 x64, 64GB RAM, Dual Xeon. Latest hotfix installed, R18 Studio

Please help, I have to pass this project to the client, rather quick :(
Title: Re: Beauty rendering black.
Post by: niedzviad on 2019-02-11, 10:37:28

Can I composite the beauty using the direct, indirect etc.?


I found the way, just linear doge add the direct, indirect, reflect, refract and translucency. But I noticed something strange too, black dots at render output.

https://imgur.com/a/BaHYkZ9
Title: Re: Beauty rendering black.
Post by: houska on 2019-02-11, 16:03:21
Hi!

Could this be an issue with NaNs (those black dots in the image)? That way when you turn on bloom and glare, it will make the output black.
Title: Re: Beauty rendering black.
Post by: niedzviad on 2019-02-11, 17:44:02
Hi! Thank you!

I've turned off bloom & glare and rendering once again. We will see what I will get.
Title: Re: Beauty rendering black.
Post by: niedzviad on 2019-02-12, 07:43:00
I've make another render turning off bloom and glare. The beauty saved correct, it is not black anymore.
But the BLACK DOTS, are still there...

https://imgur.com/vkine8Q
Title: Re: Beauty rendering black. Black dots appearing...
Post by: houska on 2019-02-12, 09:35:48
Yes, the black dots are issues with the rendering core. If you are able to share the scene with us, it would help us in fixing the issue.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-12, 09:39:06
Uploading it now :) It is a little bit heavy, but in 2hr it will be uploaded via dropbox.

Thanks looking forward to solve this :)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-12, 13:24:39
Yes, the black dots are issues with the rendering core. If you are able to share the scene with us, it would help us in fixing the issue.

Scene uploaded!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-13, 23:42:41
I've got the same problem. The black dots are copious and in some areas of the render they make a big black square.

I've got Corona Render 3 Hotfix 1 and try the render in two different machines. Unfortunately I can't upload the scene, because it's a client project.

thanks
Lorenzo
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-14, 07:22:14
I've got the same problem. The black dots are copious and in some areas of the render they make a big black square.

I've got Corona Render 3 Hotfix 1 and try the render in two different machines. Unfortunately I can't upload the scene, because it's a client project.

thanks
Lorenzo

Are you also using bloom and glare for post processing? If so, switching it off should solve this.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-14, 07:33:08
I don't use the Bloom and Glare. I post the screenshot settings. I saw this problem when I calculate the High Resolution Image: 5000pix the major side
The Cinema release is the R19

Thanks
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-14, 11:58:10

Are you also using bloom and glare for post processing? If so, switching it off should solve this.

For me it is not solved the problem. Here is crop from 8k render. https://imgur.com/a/j21fgK6 I have to deal it with Photoshop.

https://imgur.com/a/LVc2CM5
https://imgur.com/a/ZtNWCpS

Title: Re: Beauty rendering black. Black dots appearing...
Post by: harvest on 2019-02-14, 13:08:07
I've got the same problem. The black dots are copious and in some areas of the render they make a big black square.

I've got Corona Render 3 Hotfix 1 and try the render in two different machines. Unfortunately I can't upload the scene, because it's a client project.

thanks
Lorenzo

Same issue in my render :

https://imgur.com/a/JHTJAZH

EDIT:
Peew! There is more:

https://imgur.com/a/4kVZCcj


Anybody?


Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-15, 08:07:56
I have to submit any ticket? I've sent a scene and nobody didn't answer. I cant pass the renders to my client. Please help get rid of black dots.....
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-15, 09:26:42
I have to submit any ticket? I've sent a scene and nobody didn't answer. I cant pass the renders to my client. Please help get rid of black dots.....

Hi, I've actually been looking at your scene for the post few days but still haven't been able to find why it's happening or how to get rid of them. The tests I did, everything starts off perfectly and then at around pass 8-9 they appear. I still plan on looking through it again today, another user had the same issue and ended up reverting back to a previous build just to finish the job. Hopefully, a solution is near! ;)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-15, 10:33:13
I have to submit any ticket? I've sent a scene and nobody didn't answer. I cant pass the renders to my client. Please help get rid of black dots.....

Hi, I've actually been looking at your scene for the post few days but still haven't been able to find why it's happening or how to get rid of them. The tests I did, everything starts off perfectly and then at around pass 8-9 they appear. I still plan on looking through it again today, another user had the same issue and ended up reverting back to a previous build just to finish the job. Hopefully, a solution is near! ;)

Thank you for an update, I sure that the rolling back to the beta 1 will solve the problem. But I also think that if there is any bug in paid render engine it should be fixed. We're paying the sam price as 3ds max users, and the product seems to be a little bit unfinished.

I hope you will find as muc bugs as you can and release HOTFIX ASAP :)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-18, 07:48:46
I didn't forget about this topic. I have one more scene with bug to discuss :) But keep it one by one ;P
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-18, 14:20:58
I´ve a similar problem with the first interior scene with the new commercial version of corona.
In the tests it occured two times that the BEAUTY suddenly turned black :(....!!!!
In  one of these cases I could use the saved CXR (I defined in the settings that corona saves a CRX every 30min) and resume....

I had some further tests without this problem, so I set up the scene to render overnight....I waited during first 5-10 passes, all was ok so I went away...
In the morning, after 13h of rendering the Beauty-pass was BLACK again :((((((.  (I don´t want to imagine such result within a tight deadline) ...but the render was still running, producing next (black) passes(?)...so I tried to change something in the post-settings in VFB and after unchecking curves / LUT and Bloom&Glare suddenly I had a Beauty-pass again but absolutly splotchy (not a typical rendering noise) and black spots ....when checking / unchecking this 3 options the Beauty turned again black, then again to the splotchy version and so on....:((((...
This time the saved CRX were not usable, as I defined that corona holds only the last 5...and all these were corrupted (splotchy and black dots, please see the both screenshot -zoom-ins), probably all 5 saved after the "black-moment"......after same passes of resume the black spots were still there, so I canceled all this....

Is there something that should be avoided till all is fixed?...Curves, LUT, B&G?
I can wait for the Hotfix, no problem, but if I should continue to use Corona for client work, I can´t risk to have a black image after an overnight render session...and I agree with Niedzviad that it´s a little disappointing that there are more problems with paid version then with Bata....I also have some other smaller isssues that did not occure in Beta like no main image when saving as PSD file (only other passes) etc...

I also consider to work with Beta next months till such problems are fixed.....Will Beta then be still running (with the comercial licence I´ve from Version 3) after the oficial Beta-phase ends in some days?

Thanks, Artur
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-18, 14:24:48
There are two things happening, just to summarize

1) NANs are appearing in the render. This is where calculations have broken down, and they show up as black dots (if you right click on them in the VFB, rather than show numerical values, they will say NAN or Not A Number). These are always errors in the Corona code someplace.

2) If a NAN appears anywhere in a render, the Bloom and Glare pass will turn the entire image black. Disabling Bloom and Glare will prevent the entire image being black, but will not remove or prevent the NANs.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-18, 14:31:02
Thank you Tom!

I understand....
So which solution do I have? Can I have some kind of influence to avoid these Nans?
I will probably test the scene in Beta too (I hope Beta can open a file from version 3?)...If the problem doesn´t occure, can I still use Beta with the FairSaas-Licence from Corona 3?

Thanks....:) !
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-18, 14:43:29
Not sure at the moment on influence on them - usually not, but these are different than what we've seen before, in that they appear after a certain number of passes. I just rendered one of the problematic scenes, at a reduced resolution of 2,000 (down from 8,000) and reached pass 15 with no NANs; on a machine with less memory, Ben saw NANs after 8 passes or so at the same resolution. So, it could be memory related, but we don't know for sure yet and are still testing.

If your machine is getting close to maxing out the memory (e.g. C4D is using something like 26 or 27Gb out of 32Gb - the rest likely used by Windows and other stuff), it MIGHT be that reducing the resolution and so reducing memory usage might help. But until some more tests complete, we won't know for sure, sorry.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-18, 14:59:10
Hi Tom,
thanks for explanation!....There are 96GB RAM on this computer and it´s "only" an interior, so I don´t think there were some memory issues on that scene ...on the same machine some really complexe exterior scenes reaching the RAM-limits were running in Beta without problems....So I test this scene in Beta now!

Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-18, 15:36:40
Good information to know, ty!

For those who are experiencing problems, could you either a) submit the scene to us (https://corona-renderer.com/upload) or b) tell us if any plugins were used in the scene?
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-18, 17:54:14
Also, if those affected here can try re-rendering again with a different light solver other than 'auto' for example" 'scalable' I'd be interested to know if this solves the issues. Thanks
Title: Re: Beauty rendering black. Black dots appearing...
Post by: koubankeo on 2019-02-18, 21:05:14
Hi beanzvision,

I tried to set the lights on scalable and it works fine! No black dots :))))

I also found that when I turn off the surfacespread, no issue with black dots. Maybe many clones?

Thanks for your advice!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-19, 08:17:11
Also, if those affected here can try re-rendering again with a different light solver other than 'auto' for example" 'scalable' I'd be interested to know if this solves the issues. Thanks

Hi thanks, If this change will affect render times or light behavior? Did you find the bug in render engine itself?

I don't know how, but on beta never experieced any of this bugs.  Two teams was working on engine?
Title: Re: Beauty rendering black. Black dots appearing...
Post by: houska on 2019-02-19, 09:51:47
[...]

I don't know how, but on beta never experieced any of this bugs.  Two teams was working on engine?

We need to constantly update the Corona core to the newest version, because it includes important updates and fixes and sometimes also new interesting features for you. Of course, this comes with the risk that sometimes, there's a bug that comes with the new core (which seems to be this case), but these bugs are usually fixed fast and it's enough to update to a newer core version again. So bear with us and try the new daily once it's out, I think the issue might be fixed there.

Of course, we might also try not updating the core so often, but then the C4D users would have to wait for the new features for a longer period of time.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: niedzviad on 2019-02-19, 10:59:58
[...]

I don't know how, but on beta never experieced any of this bugs.  Two teams was working on engine?

We need to constantly update the Corona core to the newest version, because it includes important updates and fixes and sometimes also new interesting features for you. Of course, this comes with the risk that sometimes, there's a bug that comes with the new core (which seems to be this case), but these bugs are usually fixed fast and it's enough to update to a newer core version again. So bear with us and try the new daily once it's out, I think the issue might be fixed there.

Of course, we might also try not updating the core so often, but then the C4D users would have to wait for the new features for a longer period of time.

For me working commercially, it is better to have less bugs and less features. It is very stressful what you're struggling with bugs and the client is waiting for the viz.

Guys, keep patching the core :) Looking forward to next hotfix soon! I really keep my fingers crossed.

Changing the light solver fixed all my bugs, with strange artifacts and black dots. So for me is ok, I know how fix bugs.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: houska on 2019-02-19, 11:07:22
For me working commercially, it is better to have less bugs and less features. It is very stressful what you're struggling with bugs and the client is waiting for the viz.

That's understandable. Our development process is set up so that we limit the amount of issues in the final releases, but sometimes it can happen. But my point was that to limit the number of issues to zero, we'd basically have to stop adding new features, which is also not in the interest of you - the users.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-19, 23:49:08
I switched back to beta B2 to let render this problematic scene, that produced black dots every time  with the new corona version (once on pass 18, next time on pass 40 etc...):
Rendered with Beta 100 passes, and then overnight: No black dots....

As niedzviad already said...I´m also more happy with a version with less features but working stable....I really don´t want experience the situation that on the morning after an overnight-render and with a deadline in sight we stand in front of the screen with an unusable render with black dots ...We often have tight deadlines and the result of the work of a whole team of architects also depends on this image when a perspective is obligatory in a project / competition.

I understand that in the development (really happy about your great work :) ) something can go wrong and unexpected happens....but please consider me / our situation too...
With vray for C4D I also decided once not to use the newest version but stay with the older one, as long as problems were reported and first switched after some fixes...
So I really would appreciate the info I already asked for: Will it be possible to still use Beta2 some way with a bought licence for Corona 3...?
Thanks!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-19, 23:53:28
Also, if those affected here can try re-rendering again with a different light solver other than 'auto' for example" 'scalable' I'd be interested to know if this solves the issues. Thanks

Thanks for the suggestion...I will test it with the problematic scene and new corona in a free moment....
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-20, 12:23:55
Also, if those affected here can try re-rendering again with a different light solver other than 'auto' for example" 'scalable' I'd be interested to know if this solves the issues. Thanks

Thanks for the suggestion...I will test it with the problematic scene and new corona in a free moment....

Great, be sure to let us know the outcome. Thx
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-22, 10:01:25
I tested with the solver light Scalable and Auto. The black dots disappear, but there is a "little" problem about render time! With Scalable the render takes two hours more to reach the same noise level...
Title: Re: Beauty rendering black. Black dots appearing...
Post by: houska on 2019-02-22, 10:34:01
Hey guys,

have you tried the newest daily build already? I think it might fix the black dots. Daily builds are availabe on our Google drive: https://drive.google.com/drive/folders/1--L2vBzH3sFxSfdglqlHoxF9NCS2W2xU
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-26, 09:19:58
Hi @houska,
I tested the build you asked us to try (the one on google drive - r4) last night, with the same image, the black dots disappear (at the moment). But there is another "little" problem. With previous release if I render in Cinema4D picture viewer (Shift+R), then open the Corona VFB I saw the image and I can modify and saw all channels, now NOT.
I have the image only on picture viewer...!
Please, as I ask in open ticket, I payed for the license and I would like that it works!
I use it for work, not for hobby or game.

The beta version works perfectly....Damn...What's happened now?
Now we pay and it doesn't works!

Let me/us know asap please!

Thanks
Lorenzo
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 16:27:47
Dear Render Legion I'm waiting for a feedback! Because the build 4 too has the black dots problem!
I'm angry and disappointed!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-27, 16:39:03
Hi Lorenzo, I believe I have already replied to your support ticket, can you check?
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-27, 16:41:08
Hey guys,

have you tried the newest daily build already? I think it might fix the black dots. Daily builds are availabe on our Google drive: https://drive.google.com/drive/folders/1--L2vBzH3sFxSfdglqlHoxF9NCS2W2xU

Hi Houska,
I installed the build you mentioned and started the problematic scene: No black dots! Thank you :)!

Artur
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 16:46:47
Hi Lorenzo, I believe I have already replied to your support ticket, can you check?

I don't receive any mail
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-27, 16:57:49
Hi Lorenzo, I believe I have already replied to your support ticket, can you check?

I don't receive any mail

It was sent yesterday at 4:21pm. You had requested additional time on your license and I responded. I'd suggest double checking your mail.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: DRM - Max on 2019-02-27, 17:27:17
Hi guys, writing for my company, I’ve been in touch with your FB support, but prefer to follow up the conversation here. We bought five licences for Corona 3 and we had black dot issues, now moved to your daily build you posted on Google Drive, black dot are still there.

Your suggestion about Develop mode/Switching to light solver Scalable works but slow down the rendering time to 3-4 hours more, same scene/same project nothing changed, more than that we have black dot in new scenes created from scratch with the Corona 3 Build. I understand that’s is a temporary solution but I think you understand that in a commercial situation like ours having 3-4 hours loss of timing in each shot is a big problem, cause we deliver 5-8 images /day when in deadline, and render time is the most important feature we need.

The solution to revert to last beta (that was perfectly working) is no more a possibility due that is shut down, so at the end we have a final product that is working worst that the beta one. We are sure that you are doing the best to fix those issues, and we are glad that all your users are also tester of the product, but due that is almost a month that we are facing this issue and a real solution is still not avaliable, having acces to the last beta, at least for those who bought the licences can be a great help to have a stable/working solution while Corona 4 is a fully functional and stable release.

Hope you can help us with that as you were great to deliver a such great engine for Cinema4d.

Here attached screenshot of today’s scenes rendered with Corona 4 daily build in auto mode for the light solver, with black dots still there.
 
Thanks!

Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 17:35:48
Hi Lorenzo, I believe I have already replied to your support ticket, can you check?

I don't receive any mail

It was sent yesterday at 4:21pm. You had requested additional time on your license and I responded. I'd suggest double checking your mail.

I checked yet the mails twice but nothing. In spam folder too :). Could you please send me again? Thanks
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 17:43:36

The solution to revert to last beta (that was perfectly working) is no more a possibility due that is shut down, so at the end we have a final product that is working worst that the beta one. We are sure that you are doing the best to fix those issues, and we are glad that all your users are also tester of the product, but due that is almost a month that we are facing this issue and a real solution is still not avaliable, having acces to the last beta, at least for those who bought the licences can be a great help to have a stable/working solution while Corona 4 is a fully functional and stable release.

Hope you can help us with that as you were great to deliver a such great engine for Cinema4d.


That could be a good idea!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-27, 17:49:54

Hope you can help us with that as you were great to deliver a such great engine for Cinema4d.

Here attached screenshot of today’s scenes rendered with Corona 4 daily build in auto mode for the light solver, with black dots still there.
 
Thanks!


Hi DRM-Max,

Our scene that always produced black dots works fine now (without additional solutions lika scalable light).
I´ve seen in your screenshot that yiu installed the build from 24.01 (that I also downloaded first mistakenly ;))..there is another one in the same link provided here in thread that is from 20.02(!), we installed finally!!!
Perhaps you should install this one = the last one!

Artur
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-27, 17:58:08
Yes, testing should be done with Feb 20th daily build - that was the build where the fix was introduced. Things seem to have become a bit muddled here (at least for me) - could anyone confirm if they have the Feb 20th daily build installed, do they still see an NANs (black dots) in their renders?
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 18:07:03
I really sorry for the angry words.
About the mail, really I don't receive it. I checked all the folders.

There is the bug about the problem vfb render/picture viewer of cinema
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-27, 18:13:10
Yes, testing should be done with Feb 20th daily build - that was the build where the fix was introduced. Things seem to have become a bit muddled here (at least for me) - could anyone confirm if they have the Feb 20th daily build installed, do they still see an NANs (black dots) in their renders?

Hi Tom,

I´v already confirmed ;))) some posts before, that the scene here that always(!) produced black dots rendered overnight without problems with the build from 20.02.

Artur
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-27, 18:37:06
Thanks Artur!

Sorry about the email problems Lorenzo, we are not sure why you are not receiving those :( Sounds like all is ok as regards NANs with the latest daily build for you, but you have a new problem where a render shows normally in the PV, but the VFB is just showing black when opened. If that's correct, can I ask you to check which Multipass is being shown in the Corona VFB, does it say "Beauty" in the drop down list for that, or some other layer? (I once ran into an issue where the VFB would open and try to show a layer that it had been showing in a previous scene, but that layer didn't exist in this scene, which is why I ask). Thanks for your patience!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-02-27, 19:11:27
Hi Lorenzo, I believe I have already replied to your support ticket, can you check?

I don't receive any mail

It was sent yesterday at 4:21pm. You had requested additional time on your license and I responded. I'd suggest double checking your mail.

I checked yet the mails twice but nothing. In spam folder too :). Could you please send me again? Thanks

Of course! I'll resend it in the morning. ;)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 20:31:27
Thanks Artur!

Sorry about the email problems Lorenzo, we are not sure why you are not receiving those :( Sounds like all is ok as regards NANs with the latest daily build for you, but you have a new problem where a render shows normally in the PV, but the VFB is just showing black when opened. If that's correct, can I ask you to check which Multipass is being shown in the Corona VFB, does it say "Beauty" in the drop down list for that, or some other layer? (I once ran into an issue where the VFB would open and try to show a layer that it had been showing in a previous scene, but that layer didn't exist in this scene, which is why I ask). Thanks for your patience!

About the mail, no worry. I prefer to fix the corona bugs. :)
I render an image (5000px short side), press Shift+R (so it start in the C4D Picture Viewer), the Pc worked all night until he reached 10% of noise (to verify render time). The day after I looked the render and there was the image in the Picture Viewer but the Corona VFB was completely empty, like I never start a render. So I don't have any multipass.
Normally I started the render in PV because I use a plugin for the queue render that doesn't work if I use VFB.
Regards
Lorenzo

@beanzvision thanks
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-27, 20:46:58
Thank you Lorenzo for the description!

This has let the developers identify what is happening, and it sounds like a known issue. The issue happens if you open C4D, and start rendering to the PV without ever having opened the VFB - in that situation, the VFB will be black. The solution is to always open the VFB after C4D starts up - that can be in any scene, and you don't need to render, the VFB just needs to have been opened one time before rendering starts.

While nothing can resolve it (for now at least) once rendering starts, with that small addition to a daily workflow (as soon as C4D runs, open the VFB, don't need to render, can be any scene, and can close the VFB right away), you will be able to avoid running into this one in the future. Hope this helps, and ty for your reports!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-27, 20:52:02
Thanks TomG.
It is necessary to open a scene or just open C4D and open vfb without any scene opened?
Title: Re: Beauty rendering black. Black dots appearing...
Post by: TomG on 2019-02-27, 20:54:16
Opening the VFB in the default scene there when C4D loads is all that is needed, and you should be set from then. TY!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Vizoom on 2019-02-27, 21:16:35

The day after I looked the render and there was the image in the Picture Viewer but the Corona VFB was completely empty, like I never start a render. So I don't have any multipass.
Normally I started the render in PV because I use a plugin for the queue render that doesn't work if I use VFB.
Regards
Lorenzo

@beanzvision thanks

Hi Snowman,
when you have this problem, why don´t you go in Picture viewer to the save dialog and save the rendered image as photoshop with layers checked on...then you get a PSD-file with all the passes from corona inside as layers.

Title: Re: Beauty rendering black. Black dots appearing...
Post by: DRM - Max on 2019-02-28, 00:01:25
Oh our bad guys sorry. Thanks Artur for the tip😉. We will install the last build tomorrow and let you know if there are some issues. We need to render 5 shots so is a good way to test. Thanks all for the support. Glad the blog is here to help.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: 8snowman8 on 2019-02-28, 08:41:27
Vizoom the problem is that you can't save the cxr file, take region render etc etc... ;)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: ultranerd on 2019-03-31, 15:08:40
Any news on this. Im getting these strange issues also...
Title: Re: Beauty rendering black. Black dots appearing...
Post by: twcg on 2019-04-01, 09:27:12
Any news on this. Im getting these strange issues also...

https://corona-renderer.com/forum/index.php?topic=24228.0
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-15, 14:37:51
Hi


Yesterday I spotted again black dots. Fresh hotfix 2 installed. I used environment volumetric fog in my scene. Today I changed environment fog to a huge box object which covers my objects and added to it volumetric material ( environment fog turned off ). Now rendering running 46 passes achieved and no black dots. Anyway it looks that the beast is still hidden somewhere there :)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-04-15, 14:56:54
Hi


Yesterday I spotted again black dots. Fresh hotfix 2 installed. I used environment volumetric fog in my scene. Today I changed environment fog to a huge box object which covers my objects and added to it volumetric material ( environment fog turned off ). Now rendering running 46 passes achieved and no black dots. Anyway it looks that the beast is still hidden somewhere there :)

Can you share an example of this at all? Were there any meshes that had an alpha map used at all? I noticed something similar a while ago when rendering trees and volumetrics but these weren't NaNs (aka black dots).
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-15, 18:47:32
I'll try to restore previous "version" as attached now ( more brutal with black shape visible on snow ). This is part of the image from today. Please save image and zoom as 200% or so. Black dots are visible in glass and quite a lot of black dots areoun the scene. I added also my current version of Corona.

Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-04-16, 15:42:03
I'll try to restore previous "version" as attached now ( more brutal with black shape visible on snow ). This is part of the image from today. Please save image and zoom as 200% or so. Black dots are visible in glass and quite a lot of black dots areoun the scene. I added also my current version of Corona.
Eeek! Okay, we see what you mean. Could you possibly share this scene with us so we can investigate it? If so, the private upload link is in my signature below. This would help us very much ;)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-16, 23:08:58
Yes, of course I'll share entire scene. Today I was out of my dark deep cave of 3d production :) but tomorrow I'm going to prepare badass scene version for you. To avoid any confusion I'll prepare full 3d data without any shortcuts to restore 100% black dots rendering environment. I suppose that the file size will about 1,5 - 2 Gb.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-04-17, 12:08:12
Thanks Neb, that would be great!
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-17, 13:49:34
Hi beanzvision


I'm preparing scene for you but I have make a tests to be sure that black dots will appear. If we play in the same sandbox I have new toy which I could share to you if you would like :) . This time it's night scene and light render problem with environment fog global volume. Please take a look on the picture below. I used global volume fog material and spotted weird artifacts under the streetlight spot. It doesn't look the same always. Sometimes the shape is different. To avoid this again I changed global environmental fog to huge cube which covered entire scene and render works quite fine. Result in this topic:

https://corona-renderer.com/forum/index.php?topic=24245.0 (https://corona-renderer.com/forum/index.php?topic=24245.0)

If you would like I could share this scene too.



Title: Re: Beauty rendering black. Black dots appearing...
Post by: beanzvision on 2019-04-17, 13:58:49
Hi Neb, by all means, please feel free to submit both when you have the time. Thx ;)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-18, 11:42:06
I sent first night scene with street lights in the fog artifacts. I discovered which element causes these rendering errors. You will find at the top of the objects list street light instance object. I don't remember why I movet this object under the street object to move it out of camera visible range. When you turn on this instance the artifacts will appear. When you turn it off everything works fine. I'm not sure it it will allow you to investigate something interesting for you or it's just a mess in the scene.
I'm preparing next scene for you with blacks dots. After yesterday time consuming tests I couldn't release black dots again. I tested last scene and also two previous versions from my backups. Definietly I spotted black dots previously a few times during this project but no yesterday. I'll try again and independently of outcome I'm going to send the scene to you.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-18, 14:48:56
I'm sending by dropbox second winter scene with black dots problem. I started last test today but no black dots. I couldn't describe which factor release black dots but I spotted them a few times working on this scene. First object is a fog cube mesh. Turn it on and turn on environment global fog.
Title: Re: Beauty rendering black. Black dots appearing...
Post by: houska on 2019-04-18, 15:15:31
Hi Neb and thanks for your efforts! So the black dots are currently eluding you? :-)
Title: Re: Beauty rendering black. Black dots appearing...
Post by: Neb on 2019-04-18, 16:57:38
You're welcome!
It looks like this... I think they will appear during next project with strict deadline :)