Author Topic: Unable to load Material Library...  (Read 3761 times)

2017-10-04, 13:15:24
Reply #15

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 8782
  • Marcin
    • View Profile
Have you tried creating C:\Program Files\Corona directory with a full structure for the material library?

2017-10-04, 15:11:31
Reply #16

mike288

  • Corona Team
  • Active Users
  • ****
  • Posts: 274
    • View Profile
I attempted a search for "Program Files" in the registry, but it was far too numerous to continue.

I've had this setup (editing the registry for default program files location) working for many years now on a few computers, and this is the first time I've had an issue with a program not finding something on the correct drive. The only thing I keep on my C drive is the operating system. All third party program files and user documents are moved to other (physical) drives to prevent data loss should the operating system falter in any way.

Are you sure there isn't anything in Corona that is specifically looking for a specific drive?
Yes, I am sure. We are using an official system call to obtain a correct path to Program Files, and the path we are receiving from the system is in your case on C drive. Hence, something is wrong with your setup for 64-bit applications. Unfortunately I was not able to google what should you change to make the system call to return a path on D drive.

I am sorry I cannot help you more with this. I can just suggest you to not to do such things. Even Microsoft warns that it is not supported/tested and users should not do it (just see introduction at https://support.microsoft.com/en-us/help/933700/microsoft-does-not-support-changing-the-location-of-the-program-files).

Have you tried creating C:\Program Files\Corona directory with a full structure for the material library?
Yes, this (or just making a directory junction) would probably fix that. It could be a workaround for you.
Private uploader: https://corona-renderer.com/upload. | In case of crash, please send minidump.