Author Topic: Render Elements tab, LightSelect menu issue  (Read 331 times)

2018-04-17, 11:36:03

ThomasCoote

  • Active Users
  • **
  • Posts: 19
    • View Profile
Hi,

Starting yesterday I got this bug out of the blue. When adding a light select element and clicking on it, the "Light Select Render Element" tab immediately jumps to the top of the stack. Clicking on another element, this behaviour goes away.

Screenshots attached. This is driving me absolutely insane, any tips would be amazing.

Screenshot 1 is before clicking on the "CShading_LightMix", screenshot 2 is immediately after clicking it. If I click on the "CESSENTIAL_Direct" element, the "Render Elements" box jumps back to the top.

Thanks,


2018-04-17, 13:58:42
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2321
    • View Profile
Isn't happening here (Max 2018.4). I used a simple scene with two cubes, two Corona Lights, then added a Direct light render element, then manually added a CShading_LightSelect render element, and the Render Elements dialog always displayed as expected (immediately after creating the LightSelect, and after clicking between the Direct and LightSelect render elements).

What version of Max, and of Corona? Can you give more detailed steps that makes this happen? Maybe a short video showing it happening? Does it happen in every scene or just in specific ones?

As an aside, don't forget you'll need a CShading_LightMix element too ;)

2018-04-17, 14:09:01
Reply #2

ThomasCoote

  • Active Users
  • **
  • Posts: 19
    • View Profile
Yea it's only happening on my machine, not any of my co-workers who are all running the same software... I doubt it's a Corona issue, likely a Max issue, but I will never get a useful response on the Autodesk forums so I thought I'd ask some competent people :)

Running Max 2017, Corona 1.7 hotfix 3.

It simply started happening randomly yesterday, whenever you click on a light select element it jumps straight to the top and pushes the elements selection box down... If i manually put it back to where it should be below, this behaviour completely STOPS until next time I open the render setup dialog....

I'm hoping I can avoid reinstalling Max, as I bet that would fix it right away.

I'll see if I can get a video running later - and I only quickly made that scene to show what the problem was, I know about the lightmix element :) Which is why this is so annoying, I use it HEAVILY in my interior scenes.

2018-05-14, 11:27:46
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 8782
  • Marcin
    • View Profile
whenever you click on a light select element it jumps straight to the top and pushes the elements selection box down... If i manually put it back to where it should be below, this behaviour completely STOPS until next time I open the render setup dialog....
So it looks like some custom defaults got saved. You could try this https://knowledge.autodesk.com/support/3ds-max/learn-explore/caas/sfdcarticles/sfdcarticles/Resetting-3ds-Max-3ds-Max-Design.html
Probably not Corona-related, though.