Author Topic: [solved] setting CGeometry_ZDepth Render Element  (Read 303 times)

2018-05-14, 16:57:33

Yanosh HRDY

  • Active Users
  • **
  • Posts: 133
    • View Profile
    • www.hyh.fr
Hello,
I am trying to understand how to set CGeometry_ZDepth Render Element to have this kind of map.

I don't find any tutoriel on the web..
thank you by advance.
Yanosh
« Last Edit: 2018-05-15, 14:27:46 by maru »

2018-05-14, 17:11:43
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 8781
  • Marcin
    • View Profile
There is CGeometry_ZDepth render element for this, and the settings are rather straightforward. What exactly are you having troubles with?

2018-05-14, 18:05:29
Reply #2

Yanosh HRDY

  • Active Users
  • **
  • Posts: 133
    • View Profile
    • www.hyh.fr

2019-05-15, 13:21:00
Reply #3

vonlanthen

  • Active Users
  • **
  • Posts: 10
    • View Profile
    • kv3d.tumblr.com
? well ? im also having trouble. this is just really confusing to set up. why do i need to set "render only masks (disable shading)" on? cant i just enable the effin multipass, select render elements and im good to go? really really confusing. i kinda managed to get it but i dont know what i did and i want to understand what im doing. cant work like that. i hope they make it easier to hable all render elements.

in production i, one time, have selected the zdepth renderpass and i just got a black image. not nice after hours of rendering to get back to something like that. in vray it works. i select the freaking elements and it goes...its easy, its straight forward.

2019-05-15, 15:52:44
Reply #4

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2321
    • View Profile
You don't need to render only masks for zdepth to render, it will render quite happily along with a full beauty pass etc. If it is totally black, then the near and far ranges are not set properly for your scene - since every scene is different (close up of a watch, from 0 to 10 cm maybe, front room in a house maybe 10 feet, field outside maybe a mile), there is no "standard" or "always works" values for the near and far distances, you have to set them appropriately.