Author Topic: Proxy to mesh - set normals to average instead of explicit  (Read 556 times)

2018-06-08, 20:16:00

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 5721
  • Let's move this topic, shall we?
    • View Profile
    • My Models
I noticed that when converting Corona proxy to mesh, it gets its normals set as explicit. Unfortunately 3ds max is pretty bad with explicit normals. Would it be possible to set normals to averaged on conversion (with retaining smoothing groups, of course)?
I'm not Corona Team member. Everything i say, is my personal opinion only.

2018-06-11, 14:29:26
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9036
  • Marcin
    • View Profile

2018-06-11, 14:39:12
Reply #2

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 5721
  • Let's move this topic, shall we?
    • View Profile
    • My Models
TBH, i don't know if those two issues are related or if it's indeed the same issue. I'll try to test that, when i have more free time.
I'm not Corona Team member. Everything i say, is my personal opinion only.

2019-04-12, 09:39:02
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9036
  • Marcin
    • View Profile
Hi Romullus, could you please provide us with some simple steps how to reproduce this issue?
Is it like this?
1. Create some object, convert to poly, apply different smoothing groups to it
2. Convert to CProxy
3. Convert back to poly
4. Check smoothing groups
?

(internal id=259375618)

2019-04-12, 10:42:13
Reply #4

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 5721
  • Let's move this topic, shall we?
    • View Profile
    • My Models
..could you please disregard this request and move it to resolved board? I think my request was invalid and there's nothing inherently wrong in how Corona proxy handles normals. Sorry for disturbance.
I'm not Corona Team member. Everything i say, is my personal opinion only.