Author Topic: IES light not rendering in team render.  (Read 600 times)

2018-06-22, 20:55:55

jojorender

  • Active Users
  • **
  • Posts: 46
    • View Profile
Version: B2 daily May 30 2018 (core 2 DailyBuild May 30 2018) (same version on all nodes)
Cinema version: CINEMA 4D Studio R18.057
OS: Mac OSX 10.10.5

Hi all,
I'm using a IES file located in the "ies" folder, inside the project folder.
The IES renders fine when "render to picture viewer" on my main machine, but does not render when "team render to PV". Just the corona light renders without using the ies file.
I also tried the IES file placed in the "tex" folder (of course updated the path in corona light).
The ies only renders if the path looks like this "./filename.ies"  or "./ies/filename.ies"
If the dot in front is removed  "/filename.ies" or just "filename.ies" the light will not render.
I would assume with "filename.ies" c4d finds the file in the "tex" folder, but that's not the case.

It might be related to how c4d on mac os handles relative paths?

As a workaround I tried to use the UHD cache saved from "render to pv"
and load the file when using team render without success.
I looks like Corona still needs the ies file to calculate the light.

Can other mac c4d users confirm if ies lights work in team render.
Any ideas for a workaround?

Thank you.
MacOs 10.13.6
C4D Studio R18.057

2018-10-31, 12:57:54
Reply #1

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1234
  • Bengamin
    • View Profile
    • Cormats
Is this still an issue for you? IES is working here via TR. If you can confirm that would be great ;)

2018-10-31, 15:37:54
Reply #2

jojorender

  • Active Users
  • **
  • Posts: 46
    • View Profile
Still not working.
I'm on B2 rc 2 (core 3 (DailyBuild Oct 10 2018). Nothing related in changelogs till RC4
It must be how c4d handles relative paths in TR.
My workaround is to install the .ies file in every content browser.
Please check if attached scene works for you in TR.
Thanks.
MacOs 10.13.6
C4D Studio R18.057

2018-10-31, 16:03:05
Reply #3

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1234
  • Bengamin
    • View Profile
    • Cormats
Okay, so I have tested the file. At first, it didn't work, then I copied your ies to the Corona ies folder on both of my machines. And added it again in the light settings, directing it to Corona's ies folder. The second render worked.

2018-10-31, 16:27:17
Reply #4

jojorender

  • Active Users
  • **
  • Posts: 46
    • View Profile
Okay, so I have tested the file. At first, it didn't work, then I copied your ies to the Corona ies folder on both of my machines. And added it again in the light settings, directing it to Corona's ies folder. The second render worked.

Thanks for testing.
So, that means the TR client can't pull the .ies from the TR server machine like it does with image files in the tex folder. Is this a bug or a feature?
Not very intuitive if the ies file needs to be copied to every single TR machine by hand.
Maybe a note in the corona light ies section avoids confusion.
MacOs 10.13.6
C4D Studio R18.057