Author Topic: Vignette bug  (Read 314 times)

2019-01-18, 20:25:33

Noah45

  • Active Users
  • **
  • Posts: 418
  • press *1
    • View Profile
While working in an undocked VFB IR, I'll 'stop', then hit 'render', the vignette (rt. side) becomes too intense. 'Uncheck' tone mapping, then 'check' again, eliminates problem. Reproduced on every scene.

Latest build, Max2019
Retail Designer/ Illustrator  (for ever' 80's )
3DMax 2019/Corona Version: 3DB/ latest

2019-01-18, 20:39:43
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Unable to duplicate here, can you give more info?

Is it a Perspective view, max Camera, or Corona Camera? Is the Vignette set in the VFB, in the render settings, or in the camera? Is "Clear VFB between renders" checked or unchecked? Can you share one of the scenes (private uploader is available)?

Also, what render resolution for the final render?

2019-01-18, 20:49:04
Reply #2

Noah45

  • Active Users
  • **
  • Posts: 418
  • press *1
    • View Profile
Cameras are typically imported from Sketchup, adding camera modifier. Vignette set in VFB, not "cleared between renders."

After this DL today, I'll make a simple scene, then troubleshoot and share



Retail Designer/ Illustrator  (for ever' 80's )
3DMax 2019/Corona Version: 3DB/ latest

2019-01-18, 20:57:54
Reply #3

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Ok - if possible, could you test with a camera created natively in Max (preferably a Corona Camera), and also clearing the VFB between renders? Would be interested to know if either (or both in combination) made a difference. Thanks!

2019-01-18, 23:43:39
Reply #4

Noah45

  • Active Users
  • **
  • Posts: 418
  • press *1
    • View Profile
Test show; only happens with Standard Camera, or converted from Sketchup. No biggie, 2 clicks away from 'corrected'
Retail Designer/ Illustrator  (for ever' 80's )
3DMax 2019/Corona Version: 3DB/ latest

2019-01-19, 21:53:55
Reply #5

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Interesting! If you have the scene to share, we could take a look, may still be something that can be fixed. Cheers!

2019-01-21, 13:58:30
Reply #6

Noah45

  • Active Users
  • **
  • Posts: 418
  • press *1
    • View Profile
This scene was simplified, but still exhibits the bug.
Retail Designer/ Illustrator  (for ever' 80's )
3DMax 2019/Corona Version: 3DB/ latest

2019-01-21, 14:30:14
Reply #7

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Thanks for the scene! Unable to test the Vignette bug here, as after stopping rendering the "Cleaning Up" phase just hangs (left it for 5 minutes and it never completed - Max CPU usage was at 0% almost immediately). I'll use this scene to report the freeze for now. If we can get it working without the freeze, we'll move on to trying to replicate the Vignette bug.

Note to self, 310358580
« Last Edit: 2019-01-21, 14:39:28 by TomG »

2019-01-21, 15:27:14
Reply #8

Frood

  • Active Users
  • **
  • Posts: 1241
    • View Profile
    • Rakete GmbH
If we can get it working without the freeze

Try to disable B&G if active (or switch vfb tabs off/away from post settings). Could not check this scene in particular (no 2019 available) but in other scenes, B&G (or progress bar) was the cause for those render end freezes.


Good Luck


Never underestimate the power of a well placed level one spell.

2019-01-21, 15:43:22
Reply #9

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Disabling that did the trick and let the render stop. I'll make sure we have that logged somewhere on the system :)

On doing that though, I did not see the Vignette darkening as reported though. Meantime, out of interest, Noah, does disabling Bloom & Glare have any effect on the Vignette bug for you?

Here were the steps I tried
Load the scene
Turn off the NVIDIA denoiser during rendering (might be something to try and see if it changes the bug, Noah)
Open the VFB from the toolbar
Render
Wait until it had started rendering pass 2 (so 1 pass complete)
Press Stop in the VFB
Press Render in the VFB
No Vignette darkening shown

Let me know if your steps are any different Noah.

2019-01-21, 15:52:01
Reply #10

Noah45

  • Active Users
  • **
  • Posts: 418
  • press *1
    • View Profile
Try this Tom;

Undocked VFB full screen, hit "start IR"
2-3 passes hit Stop
Hit Render, that should reproduce it


Retail Designer/ Illustrator  (for ever' 80's )
3DMax 2019/Corona Version: 3DB/ latest

2019-01-21, 15:56:46
Reply #11

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Try this Tom;

Undocked VFB full screen, hit "start IR"
2-3 passes hit Stop
Hit Render, that should reproduce it

Still did not see the unexpected effect :(

2019-01-21, 16:05:23
Reply #12

Frood

  • Active Users
  • **
  • Posts: 1241
    • View Profile
    • Rakete GmbH
I'll make sure we have that logged somewhere

See ticket #15893


Good Luck


Never underestimate the power of a well placed level one spell.

2019-01-21, 16:07:56
Reply #13

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2318
    • View Profile
Can't access the ticket system (well, I can, but I don't usually), but did find the related task in our internal tracker and added info to it :) Cheers!