Author Topic: [solved] shadowcatcher behind glass  (Read 181 times)

2019-03-04, 10:07:43

nicolas7755

  • Active Users
  • **
  • Posts: 14
    • View Profile
Hi everybody

I have the following scenario in an animation project: I'm standing inside a room looking out through a window. To the ground outside I applied a ShadowCatcher Material, so I can later compose everything correctly (the background will be replaced by real footage an there are animated objects on the ground happening).
This works fine as long as I disable the window glass. When I turn it on, the shadowcatcher doesn't work anymore (same with the alpha - the ground plane becomes visible).
How can I make this work?
I thought I could simply disable "visible in masks" in the glass material, but this doesn't change anything.

Best wishes
Nicolas
« Last Edit: 2019-03-12, 17:51:16 by maru »

2019-03-05, 11:42:53
Reply #1

nicolas7755

  • Active Users
  • **
  • Posts: 14
    • View Profile
Any ideas on this? :-)
Or do I simply have to render twice.

2019-03-06, 19:11:18
Reply #2

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 8612
  • Marcin
    • View Profile
Does it work if you change the refraction mode of your window glass to "thin"? It would have no refraction then.
Generally, at this time it's a limitation of Corona (rendering masks in refraction/reflections). It will be improved in the future.

2019-03-11, 09:07:52
Reply #3

nicolas7755

  • Active Users
  • **
  • Posts: 14
    • View Profile
Hi maru

Thanks for your reply, changing the refraction to thin did the trick.

Best wishes
Nicolas