Author Topic: NaN  (Read 76 times)

2019-04-03, 14:33:15

++MLK++

  • Users
  • *
  • Posts: 3
    • View Profile
NaN
Hello.
I am experiencing troubles with our renderfarm and a lot of NaN. See the preview below

I can not share the scene so here some specs :

We are using corona 3 (not sp1) with max 2018 sp4 on w10 x64 1809
Railclone3.2, forest 6.1.2
Lens distortion on cam
Displacement (preview actually, still in sceen space 10px + autobump)
Using UHD, precise mode + new light solver
filter blackmann 2.5px, hilights clamp at 10, shading clamp at 15
direct sample 2, givsaa 24
environment override + linear exr
visible bg override to pure black
no tonemap, no bloomglare, no lut, no blur/sharping or anything vfb related since it's comped in nuke.
only coronamtl and corona related assets (coronabitmap, layer etc)
no irregular stuffes like rayswitchers etc.
using cessentiols, lightselect (no lightmix buffer) and some datachannels(pos, uv, velocity, z etc.)
denoising 9 renderelements (essentiels and light select) with cpu/prod denoiser
Saving exr rgba half float premult zip as scanline

As you can see on both column (different frames), lots of nan.
I think the problem is related to exr cause as you can see, the light select (either sun or environment) have no problem. But the beauty and essentials (all) have nan. Alpha, velocity, worldpos, z depth and others datas are ok.
I would like to avoid upgrading the whole agency to corona 3 sp2 this Week cause my deadline is tight. And usually we do not upgrade sofwares during production timeframe. And i can not be sure it will solve the issue...
Actually i comp-build the beauty with nuke and bust nans with a "secondary" beauty rebuilt from the 3 lights selects components i have (sun, env, and artificials) but it prevents me from using others buffers.

Here are others informations i did not tested very much so it's hard to say if it's really involved or not but it seems :
- saving jpg reduces the problem and maybe resolve it (but i may not comp with jpg)
- using double path tracing (instead of uhd) reduces the amount of problematic frames
 -disabling new light solver reduces the problem

I am pretty aware you cannot solve the issue just looking at a frame on a forum, but can you tell me what produces nan in general with corona ?
Thanks

2019-04-03, 14:45:28
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2273
    • View Profile
NaN's (Not a Number) come up when, for example, a calculation results in a divide by zero.

In the version of Corona you are using, turning off the New Light Solver should remove the NaNs (the possibility that this might happen is why the New Light Solver is not on by default in Corona 3). Alternatively, the latest daily builds of Corona 4 should allow the New Light Solver to work without NaNs.

2019-04-03, 15:13:23
Reply #2

++MLK++

  • Users
  • *
  • Posts: 3
    • View Profile
Ok thanks for your quick reply
I'll disable nls and keep you informed on the next version
we will upgrade so sp2 asap.

Regards.

2019-04-03, 15:36:05
Reply #3

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 2273
    • View Profile
Yes, Corona 3 (Hotfix 1) should resolve this issue, as well as daily builds (be as well installing Corona 3 (hotfix 2) if you are updating - even though only change in hotfix 2 is support for 3ds Max 2020 :) )