Author Topic: (Daily Build 2019-05-03) Bump Tex doesn't update properly in IR  (Read 182 times)

2019-05-10, 12:21:00

nkilar

  • Active Users
  • **
  • Posts: 760
    • View Profile
    • My personal website
Hello :) Found a bug!

With IR enabled:
- Plug a texture into the bump map slot -> IR updates properly
- Replace the texture with another different texture -> IR refreshes but doesn't show the updated bump map, still shows the previous texture.

Pretty much that. I can reproduce it fairly easily although sometimes it appears to update properly.

2019-05-10, 16:56:18
Reply #1

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1213
  • Bengamin
    • View Profile
    • Cormats
Hi Nejc,

Thanks for the report. I can also confirm this. I'll note it in our internal bug report. ;)

- Update. I did notice that the IR will update eventually if you keep changing the texture. The first change had no effect but any texture change after that the IR updated as expected. Is this happening to you also?
« Last Edit: 2019-05-10, 17:01:43 by beanzvision »

2019-05-13, 22:41:43
Reply #2

nkilar

  • Active Users
  • **
  • Posts: 760
    • View Profile
    • My personal website
Almost missed your reply :) I'll try it out and report back!

2019-05-14, 10:38:40
Reply #3

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1213
  • Bengamin
    • View Profile
    • Cormats

2019-05-30, 10:10:53
Reply #4

nkilar

  • Active Users
  • **
  • Posts: 760
    • View Profile
    • My personal website
Yeah so I kinda feel off the map for a bit there... Anyway, I tried reproducing this behavior in the latest daily and it regressed up to a point where all the material channels exhibit the same behavior.

Changing the texture after it gets "stuck" doesn't update it either. You literally need to restart the IR to get the right texture to show up although that might be something that the newest build introduced.