Author Topic: Light Mix - glare points in the scene - how to remove them?  (Read 3047 times)

2017-05-10, 20:33:37

zbieraj

  • Active Users
  • **
  • Posts: 94
    • View Profile
As in the the topic title. This is the situation:


2017-05-11, 09:28:40
Reply #1

nkilar

  • Active Users
  • **
  • Posts: 816
    • View Profile
    • My personal website
I am thinking you perhaps started with a daylight scene and then created a night time scene out of it using lightmix? If that is the case then... Lightmix probably might not cut it. It is best used for "smaller" changes but depending on the scene you might actually get away with a day / night cycle.

Sooo... That really isn't a suggested solution but... For those types of glares / fireflies I'd suggest using the denoiser at a more cranked up level - And don't forget to turn it on for lightmix as well!
« Last Edit: 2017-05-11, 11:08:35 by nkilar »

2017-05-11, 10:26:00
Reply #2

houska

  • Corona Team
  • Active Users
  • ****
  • Posts: 1329
  • Cestmir Houska
    • View Profile
nkilar seems to be right. You have a lot of variance (=noise) in the light emitted by the lamps, which probably means that you rendered the picture with their light tuned down a lot. Changing this in the lightmix will then multiply the variance and make it more visible. Simple rule for the lightmix - you can change the colors, you can tune down lights, but never ramp them up!

2017-05-11, 10:59:59
Reply #3

zbieraj

  • Active Users
  • **
  • Posts: 94
    • View Profile
That is the case. The whole model is prepared for the daylight renders but I wanted to have one late afternoon one...

I turned on denoising in the multi-pass. Didn't help at all (beside helping reducing noise).


2017-05-11, 11:01:06
Reply #4

zbieraj

  • Active Users
  • **
  • Posts: 94
    • View Profile
You are right - be the default the lights are almost turned off. So should I the make opposite - make the lights already super bright to dim them down?

2017-05-11, 12:04:51
Reply #5

zbieraj

  • Active Users
  • **
  • Posts: 94
    • View Profile
Okay, so it helped! Thanks!

What I did - I had emission of the light having value of 10. I increased it to 1000. It meant that I had a bit overexposure scene but then I reduced the amount of light in the LightMix. No glare points scattered randomly in the scene :).

Having said that - I will now use a lot of energy for this night render to look more realistic. Artificial lights are problematic for me :D.

Thanks guys!

2017-05-11, 12:52:45
Reply #6

houska

  • Corona Team
  • Active Users
  • ****
  • Posts: 1329
  • Cestmir Houska
    • View Profile
Okay, so it helped! Thanks!

What I did - I had emission of the light having value of 10. I increased it to 1000. It meant that I had a bit overexposure scene but then I reduced the amount of light in the LightMix. No glare points scattered randomly in the scene :).

Having said that - I will now use a lot of energy for this night render to look more realistic. Artificial lights are problematic for me :D.

Thanks guys!

You are welcome. Overexposing the image is not necessary, the only thing you should remember is not to use lightmix to make lights (significantly) brighter.

2017-05-15, 22:11:28
Reply #7

lenogre

  • Active Users
  • **
  • Posts: 103
    • View Profile
I hope, in the future, we can apply glare/bloom with a compositing tag like we can do with AR in c4d for post-effects.

2017-05-16, 11:15:08
Reply #8

hog0

  • Active Users
  • **
  • Posts: 65
    • View Profile
there is an easy solution to your problem, that at least works for me pretty good when working on a day-2-night-shots within the same rendering:

1. overdo your lights, a lot ... so if your light bulps usually would have intensity 1, make them 10 or even 15 (yes they are very bright now), same for every other light / sky / lightgroup / group of same light ..
2. set up your sun as you would for a normal daylight shot
3. do your normal rendering and let it denoise
----------
4a. daylight:
reduce your sky value and disable/reduce interior/exterior lights that would not be "on" or very visible during the day in lightmix - change sun/skycolor if needed - daylight done

4b. sunset/night:
reduce/lower your sun intensity to whatever suits your needs, same for the sky and all other lights, change intensity/color/temp in lightmix.. - sunset done
----------

the whole reason why you had to overdo light intensity on all the lights, even tho you wont use them that bright, is that after the denoising, the image hase a lot more information on how/what every single light/lightgroup would illuminate. that way you reduce fireflys, brunspots, brightspots and your lights have a very soft falloff.

its already been said, using a value of 1000 on a light may be too much, but reducing it on lightmix to 250 for a nice look, is perfectly fine..

give this a try on low res if you dont belive me right away ;)

2017-05-16, 18:08:36
Reply #9

Cinemike

  • Active Users
  • **
  • Posts: 484
    • View Profile
there is an easy solution to your problem
...
give this a try on low res if you dont belive me right away ;)
Thank you for your thorough explanations!
I will give them a try with my next interior (being an "outdoors rendering guy" most of the time, I have not yet used light mix very often).
I just need to remind myself that, contrary to photography, overexposing is a good thing here.

CU
Michael