Author Topic: CoronaLights "prevent black appearance" ignored if behind a refractive material.  (Read 1941 times)

2017-06-19, 00:19:06

matsu

  • Active Users
  • **
  • Posts: 56
    • View Profile
I am lighting an interior with CoronaLights. The lights have directionality and I have the "prevent black appearance" checked. Directionality set to 0.5.

Camera is placed outside of the building. There are glass windows between the lights and the camera.

If I render the scene with the glass in place (that is in front of the lights) they turn black, i.e. the effect is ignored. If I hide the glass, the effect is working properly.

Surely, this can't be intended?

2017-06-19, 16:19:19
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9778
  • Marcin
    • View Profile
Currently the "prevent black appearance" option only works for direct visibility, so black lights will be still visible in reflections and refraction. Hopefully this will be soon improved.

2017-06-20, 04:20:06
Reply #2

matsu

  • Active Users
  • **
  • Posts: 56
    • View Profile
Alright. Good to know that you know. Hoping for a fix in the near future. :)

2018-04-13, 17:17:16
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9778
  • Marcin
    • View Profile
Just an update on this:
Currently this is expected (lights may still appear as black when seen in reflections or refractions).
We would like to fix it, however it will require a lot of work and caution not to break something else.

There is a workaround for this (using Corona Light Mtl instead of light objects):
-use the rayswitch material: standard light mtl should be used for GI, and light mtl with "emit light" option off should be used for direct visibility, reflections, and refraction.