Author Topic: Shadow catcher not reflecting lights  (Read 1460 times)

2017-08-19, 02:30:15

3di

  • Active Users
  • **
  • Posts: 128
    • View Profile
shadow catcher doesn't reflect corona light material.  it does reflect self illumination though..
« Last Edit: 2017-09-01, 10:34:44 by maru »

2017-08-19, 02:57:14
Reply #1

3di

  • Active Users
  • **
  • Posts: 128
    • View Profile
correction, the reflection of the object with the corona light material doesn't appear in the shadow catcher reflections when the corona light material is applied directly to the object....but it does appear in the shadow catchers reflections when applied within a multi/sub-object map.  In this instance it appears in the beauty pass but not in the alpha channel meaning it cant be used for compositing.

2017-08-19, 03:17:55
Reply #2

3di

  • Active Users
  • **
  • Posts: 128
    • View Profile
I've just tried using corona lights instead of light material, and they also dont reflect in the shadow catcher.  Shadow catcher bug then?

2017-08-21, 16:25:55
Reply #3

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9052
  • Marcin
    • View Profile
Have you tried the "shadowcatcher illuminator" option in both the Corona Light and Light mtl? ;)

2017-08-23, 02:41:48
Reply #4

3di

  • Active Users
  • **
  • Posts: 128
    • View Profile
Hi Maru I'm now using version 1.6.2 and now the opposite is happening.  The lights reflection is white in the renders alpha channel (as it should be), but in the beauty pass it's showing as black.....

[EDIT] Strangely it's now gone back to the the previous behaviour of subtracting the lights reflection from the alpha channel [EDIT]

I've also tried turning shadow catcher illuminator on, but this just seems to stop the light reflecting at all in the shadow catcher...or even more strangely, intermittently has no effect at all.

steps to recreate.

  • Create a plane.
  • create a corona light and place near the plane.
  • create shadow catcher material with enviro/backplate set to black, alpha mode set to "for compositing" with reflection properties level 1, colour white, fresnel 999, glossiness 1.
  • corona render settings set direct visibility overide to black.
  • run interactive render, lights reflection is subtracted from the renders alpha
  • turn on shadowcatcher illuminator checkbox and check bueaty and alpha passes in the render window (nonsensically, sometimes this gets rid of reflections sometimes it makes not difference.)

I should point out that everything works correctly when choosing alpha mode "always solid".

Please see attachments for better understanding.
« Last Edit: 2017-08-23, 03:27:08 by 3di »

2017-08-25, 11:55:12
Reply #5

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9052
  • Marcin
    • View Profile
Ok, moved back to bug reporting, sorry for the hassle.

It might be by design, as explained here: https://corona-renderer.com/forum/index.php?topic=7935.msg62666#msg62666
So if the lighting or reflection would be visible, it probably wouldn't be possible to composite it correctly.
But I will leave this thread here unless the developers decide to move it back to resolved.

Currently I cannot find any solution to this, other than loading the backplate directly in Max, and rendering the image with the shadowcatcher in "solid" mode instead of "for compositing".

2017-08-25, 12:14:32
Reply #6

3di

  • Active Users
  • **
  • Posts: 128
    • View Profile
Thanks Maru. 

Unfortunately that workaround isn't possible as the client wants to the option of changing the background himself occasionally.