Author Topic: Incorrect shading on imported geometry  (Read 832 times)

2018-01-08, 23:43:25

dcode

  • Active Users
  • **
  • Posts: 7
    • View Profile
Hi ,

I am working in version 1.6 and my imported polygon geometry (converted from Rhino) is not shading correctly.
I tested in Vray and Fstorm and got the expected results so it is a Corona issue.
Attached are quick screen grabs and 3D File.

Tested on both a dual Xeon E5-2687 and Threadripper on Win 7 and 3DS Max 2016

Cheers,

2018-01-09, 10:04:22
Reply #1

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 8350
  • Marcin
    • View Profile
Have you tried using the "smooth" modifier, or selecting all faces and using "retriangulate" option in editable poly tools?

Another idea is disabling the terminator fix and checking if it helps:
-go to development/experimental rollout - https://coronarenderer.freshdesk.com/support/solutions/articles/12000021288
-under "terminator handling" set shadow shift to 1

If that does not help, it would be best if you could send us the scene - https://corona-renderer.com/upload

2018-01-09, 11:08:08
Reply #2

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 5177
  • Let's move this topic, shall we?
    • View Profile
    • My Models
@maru, i think the scene is already attached to the original post. As for smoothing options, usually geometry from CAD softwares comes with explicit normals and almost any manipulation inside 3ds max, would ruin those beyond repair.

2018-01-09, 11:08:51
Reply #3

pokoy

  • Active Users
  • **
  • Posts: 1280
    • View Profile
Maru, geometry from Rhino or other CAD packages will import with its own set of explicit normals, using the smooth command or modifier will ALWAYS result in worse shading.

It's likely that this is the shadow terminator fix wich doesn't work well (at all) with explicit normals. Follow Maru's suggestion and set it to 1 to disable it.

BTW, Corona should either get a fix so it supports explicit normals in the shadow terminator fix (preferred) or it should throw a warning when a mesh with explicit normals is found upon render start, together with instruction on how to disable it. Chances are more people from the CAD world face the problem but don't ask for help here and instead give up on Corona thinking it can't render CAD geometry.

2018-01-09, 12:38:01
Reply #4

NicolasC

  • Primary Certified Instructor
  • Active Users
  • ***
  • Posts: 386
  • Primary Certified Instructor
    • View Profile
    • Intangibles Assets Design
Hello,

I've just found that, not sure it will help you, dcode, but worth trying:
http://polycount.com/discussion/181833/any-way-to-transfer-explicit-normals-to-smoothing-groups-in-3dsmax

Nicolas Caplat

3d Dept Manager / Intangibles Assets Design / Paris

2018-01-09, 12:58:05
Reply #5

pokoy

  • Active Users
  • **
  • Posts: 1280
    • View Profile
Hello,

I've just found that, not sure it will help you, dcode, but worth trying:
http://polycount.com/discussion/181833/any-way-to-transfer-explicit-normals-to-smoothing-groups-in-3dsmax
This is something else I guess. The point is to keep the explicit normals (and NOT using max smoothing routines). The problem is that Corona's terminator fix doesn't play well with explicit normals and this should get fixed, for the time being the only way to get artifact-free renders with explicit normals is to disable it.

See post #14 here:
https://corona-renderer.com/forum/index.php?topic=18509

2018-01-09, 15:24:22
Reply #6

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 5177
  • Let's move this topic, shall we?
    • View Profile
    • My Models
Hello,

I've just found that, not sure it will help you, dcode, but worth trying:
http://polycount.com/discussion/181833/any-way-to-transfer-explicit-normals-to-smoothing-groups-in-3dsmax

That could only work if original model would be created as polygonal with smoothing groups, then exported and reimported with explicit normals, but without smoothing groups. But that wouldn't help with imports from CAD.

2018-01-09, 15:27:04
Reply #7

NicolasC

  • Primary Certified Instructor
  • Active Users
  • ***
  • Posts: 386
  • Primary Certified Instructor
    • View Profile
    • Intangibles Assets Design
okok I get it ;)
Nicolas Caplat

3d Dept Manager / Intangibles Assets Design / Paris

2018-01-09, 18:11:23
Reply #8

edin_2016

  • Active Users
  • **
  • Posts: 25
    • View Profile
Wrong Tread, sorry; same problem in c4d ...

-> https://corona-renderer.com/forum/index.php?topic=18794.0
« Last Edit: 2018-01-09, 18:16:04 by edin_2016 »

2018-01-09, 18:52:15
Reply #9

dcode

  • Active Users
  • **
  • Posts: 7
    • View Profile
Hi guys,

Thanks so much for the prompt  help, indeed you are all correct!
One of our poly modelling hotshots here had a look at the smoothing and normal options and gave up mentioning exactly what you said about explicit normals, so adjusting the shadow terminator shift completely worked!

Thank you!

Maru, the file is attached to the thread in case you ever need an example of this case but more than happy to upload somewhere else if required.