Author Topic: **Solved** Issues with Shadow Catcher  (Read 1159 times)

2018-05-11, 22:35:21

BigAl3D

  • Active Users
  • **
  • Posts: 234
    • View Profile
OK so in my quest to render convincing cars that I can comp into images and footage, I'm having an odd issue. Maybe I'm missing something. My Sky material and Shadow Catcher material are not automatically lining up in my renders. In the attached image, you can see where I tried to line them up right above the dark green car. The images are also backward, but the actual image is not. The background also renders a lot softer that the actual image is. The other thing down the line would be to do the actual compositing in AE and blend them together better there. Can the Shadow Catcher, at this stage or in the future, export a shadow pass separately?

Yes, I have watched the few videos covering this with C4D, but it's very simple and I'm following the steps. Any advice and getting better at this is appreciated.

« Last Edit: 2018-05-18, 20:45:30 by BigAl3D »

2018-05-11, 23:54:01
Reply #1

mrittman

  • Active Users
  • **
  • Posts: 232
    • View Profile
    • www.mattrittman.com
Just throwing this out there, as I was doing something similar lately... In your C4D project settings, does your width and height match the same ratio as the image you're using?

2018-05-12, 00:16:00
Reply #2

BigAl3D

  • Active Users
  • **
  • Posts: 234
    • View Profile
You mean my output size matching my image (sky) I'm comping into? No it wasn't, but I made them the same is I have the same problem. I know it should work similar to the Camera Projection feature.

2018-05-12, 00:33:43
Reply #3

mrittman

  • Active Users
  • **
  • Posts: 232
    • View Profile
    • www.mattrittman.com
Yeah. Dang, I thought that would have fixed it. Haha then I dunno man :(

2018-05-18, 20:43:57
Reply #4

BigAl3D

  • Active Users
  • **
  • Posts: 234
    • View Profile
Turns out that by deleting the Shadow Catcher material and the Sky material and recreating them, everything went back to normal as far as lining up.

2018-05-18, 21:01:28
Reply #5

mrittman

  • Active Users
  • **
  • Posts: 232
    • View Profile
    • www.mattrittman.com
Oh good haha! Glad you were able to resolve the issue :)