Author Topic: Tone map shader invert button doesn't work correctly  (Read 685 times)

2018-09-09, 18:07:24

monkriss

  • Active Users
  • **
  • Posts: 43
    • View Profile
If i have a texture which is a roughness map but I need to plug it into the gloss input for Corona, I need to invert it so I use the tonemap shader.
However, the tone map shader invert button doesn't appear to work correctly and instead puts the gloss to almost 100% gloss/ignores the map altogether

If I use the colour ramp and switch the white and black input (to invert the texture) it works correctly.


If I use the tone map shader invert button. its wrong


If i set the gloss to 100%, it looks exactly the same as setting the tone map shader to invert.


So its almost as if the invert button just completely makes it ignore the texture altogether?


2018-09-09, 18:08:21
Reply #1

monkriss

  • Active Users
  • **
  • Posts: 43
    • View Profile
Sorry the images didn't attach?


Here it is with 100% gloss
https://imgur.com/a/N5F82V7

Here it is with tone map shader (same as the one above)
https://imgur.com/a/Z51v9I0

Here it is with colourramp, which is how it should looK
https://imgur.com/a/N87APrO

2018-09-09, 23:03:42
Reply #2

blanchg

  • Moderator
  • Active Users
  • ***
  • Posts: 373
    • View Profile
    • Blender exporter for Corona
Can you show me the multiply values on the tone map and the .mtl file that is generated.

2018-09-11, 09:09:03
Reply #3

monkriss

  • Active Users
  • **
  • Posts: 43
    • View Profile
Hey,

here is a file for you with a glossy map and the tone map shader set up, along with the .mtl file :)

2018-09-15, 23:38:19
Reply #4

blanchg

  • Moderator
  • Active Users
  • ***
  • Posts: 373
    • View Profile
    • Blender exporter for Corona