Author Topic: IES color not rendering in Corona 3?  (Read 335 times)

2019-02-15, 00:44:56

Konichowaa

  • Active Users
  • **
  • Posts: 19
    • View Profile
Hi,

Is it possible that in corona 3, IES color is not rendered? I see no change when changing the color saturation, even when set to 100%.

It also seems to reset the color settings (at least saturation) to zero when loading an older file or object from content brwser, which is very inconvenient...

edit:
after some testing, I found that the light itself is rendering OK, but when it is instanced (not "render instanced" but just instanced in a fixture) or inside a cloner, the coloring is neglected.
When making the instance editable again, the color is still neglected.

can someone reproduce this error?

on image: right is regular light. middle is instance of regular light and to left wall regular light inside cloner
« Last Edit: 2019-02-15, 01:41:22 by Konichowaa »
Koen Van haesendonck
3D-lab - www.3d-lab.be

2019-02-19, 12:45:50
Reply #1

Exactly

  • Active Users
  • **
  • Posts: 7
    • View Profile
I get the same results when using the cloner. Seems to ignore the colour no matter what instance mode the cloner is set to.

If you use a normal Instance object on the Corona light instead of the cloner it seems to work though (just make sure the mode is set to render instance).

2019-02-20, 23:17:01
Reply #2

Konichowaa

  • Active Users
  • **
  • Posts: 19
    • View Profile
I found out indeed that it is not related to IES specifically but to lights that are instanced by instance object, cloner, symmetry object etc (generators)...

in the two attachments I get the same result with IES light and as area light with IES disabled.

from left to right I have placed:

Left Left  : Regular Instance object of the centre symbol including the light
Left         : Original fixture symbol (mesh) with Regular Instance object of the light source
Centre     : Original fixture symbol (mesh) with original light source
right        : Original fixture symbol (mesh) with Render Instance Object of the light source
right-right : Render Instance Object of the centre symbol including the light

As you see, I can't render the light at ALL with "render instance" enabled (just like I never could in earlier corona betas and/or vray)
can you check if you can? I included the test file...
Koen Van haesendonck
3D-lab - www.3d-lab.be

2019-02-21, 10:56:47
Reply #3

davetwo

  • Active Users
  • **
  • Posts: 40
    • View Profile
I had a quick look at the file.
I put the light into a cloner - and indeed it didn't transfer the colour to the cloner instances.
BUT, when I used Temperature instead of Colour as the colourisation method, it worked fine. So perhaps this will be a decent fix  for now

2019-02-22, 14:53:03
Reply #4

Konichowaa

  • Active Users
  • **
  • Posts: 19
    • View Profile
Thank you!
I can verify that indeed using temperature is the best workaround for now! I don't really love the hue on that, but at least I can keep my prepared symbols as is, and stay organized!
I still hope though, that a fix is coming soon...
Koen Van haesendonck
3D-lab - www.3d-lab.be