Author Topic: IR, ForestPack and lowering of viewport perfomance  (Read 503 times)

2019-04-09, 13:03:47

Bormax

  • Active Users
  • **
  • Posts: 377
    • View Profile
Hello

I work mostly with exterior visualization and I use ForestPack for greenery instancing. Almost in every project I have the same problem using IR - if FP's objects (especially grass which normally covers large areas in my project) are not hidden, viewport performance gets dramatically low - even if FP's objects are not renderable and amount of displayed items is pretty low. If they are hidden viewport performance gets normal. I tried to find better solution than hide FP objects every time I want to use IR, and the one I found is switch viewport appearance of the instances to some proxy type from the default Points-Cloud.
I believe solution of this problem should be done by Itoo, but maybe would be good if Corona team will contact them about this issue which connected with Corona's IR.
Hope this information will help to the ones who has this problem, of course if I'm not the only one who has it :)

2019-04-09, 15:28:35
Reply #1

fellazb

  • Active Users
  • **
  • Posts: 278
    • View Profile
Same here. Not sure if it's related to MAX 2019, Corona 3.x or FP but I didn't have it before. For now I have all my forest pack objects in a layer to easily turn them on and off but a better viewport performance would be highly appreciated.

2019-04-09, 15:58:17
Reply #2

danio1011

  • Active Users
  • **
  • Posts: 199
    • View Profile
Yes, same problem with Max 2016 and 1080 Ti.  My imperfect solution is to change from point cloud to pyramid and drop visible instances to 500 or something very low.  Not a great solution, I’m sorry to hear newer versions of Max have the same issue.

2019-04-09, 17:16:48
Reply #3

Bormax

  • Active Users
  • **
  • Posts: 377
    • View Profile
For now I have all my forest pack objects in a layer to easily turn them on and off but a better viewport performance would be highly appreciated.

I use the same way. But it's annoying, especially if I forgot to do it, started IR and my viewport has frozen.
I've got the same results on 2016 and 2014 Max, so it's not only 2019's issue

Yes, same problem with Max 2016 and 1080 Ti.  My imperfect solution is to change from point cloud to pyramid and drop visible instances to 500 or something very low.  Not a great solution, I’m sorry to hear newer versions of Max have the same issue.

I do the same
« Last Edit: 2019-04-09, 17:22:19 by Bormax »

2019-04-09, 17:23:37
Reply #4

alexyork

  • Active Users
  • **
  • Posts: 517
  • Partner at Recent Spaces
    • View Profile
    • RECENT SPACES
Point cloud is all-but unusable in max, really, unfortunately. We use proxy display mode all the time now. Clouds disappear during IR, which is a huge pain too.
Alex York
Partner
RECENT SPACES
recentspaces.com

2019-04-23, 22:27:15
Reply #5

danio1011

  • Active Users
  • **
  • Posts: 199
    • View Profile
We just ran through a smaller project on Vray Next Gpu for the first time in a while just to test out some new 2080 Tis.  I noticed it was a bit more responsive during IR with lots of Forest Pack.  It seems like the slowdown with Corona + Viewport + IPR happened when Forest Pack 6 came out and you were able to live edit.  I might be misremembering?  Anyway, just makes me wonder if Vray and Corona work with FP slightly differently and/or if there’s room for optimization with Corona.

Cheers!
Daniel

2019-04-24, 02:54:06
Reply #6

arqrenderz

  • Active Users
  • **
  • Posts: 695
  • arqrenderz.com
    • View Profile
    • arqrenderz
Try the freeze objects on the display tab of itooforest, we solved a viewport problem with it.