Author Topic: Instance ies lights don't show in reflective surfaces  (Read 810 times)

2019-09-11, 17:06:56

friedli3d

  • Active Users
  • **
  • Posts: 33
    • View Profile
Hello all,

I was facing a problem with a render that I was doing, and I notice that a light that is an instance of a light with ies , don't show in a mirror that I have. Is there anyway to correct this?

Thank you all



2019-09-16, 12:11:38
Reply #1

brankonovakovic

  • Corona Team
  • Active Users
  • ****
  • Posts: 15
    • View Profile
We will investigate this, thanks for reporting it. In the meantime, you will have to un-instance the affected light (make it unique).
Regards,
Branko.

2019-09-18, 01:26:04
Reply #2

daveclive

  • Active Users
  • **
  • Posts: 87
    • View Profile
make sure render instance is selected from he drop down, not just instance

2019-09-18, 09:59:55
Reply #3

houska

  • Corona Team
  • Active Users
  • ****
  • Posts: 1335
  • Cestmir Houska
    • View Profile
Guys, this is a feature of the "prevent black appearance" option for the lights. The thing is that it doesn't work in reflections or refractions. So your directional light will look white when viewed directly, but it will stay black when viewed in a mirror. This is not easily solvable because it's an unrealistic hack and because it's not exactly clear, in which situations the light should return white and when it should be invisible. For now, you can use a rayswitch material to circumvent this limitation.

Edit: So without seeing the scene and having more info, I would say that this has nothing to do with instancing!

2019-09-18, 10:32:30
Reply #4

friedli3d

  • Active Users
  • **
  • Posts: 33
    • View Profile
thank you all for your replies!

I will test later to see if the problem is with instancing and will report it.

once again, thank you all

2019-09-19, 08:38:37
Reply #5

friedli3d

  • Active Users
  • **
  • Posts: 33
    • View Profile

I tried with all different instance mode, render in interactive rendering and normal just to see if there were any changes, but unfortunately the solution I found is use normal light non instance.

thank you all