Poll

Do you think Interactive Rendering is slower than it used to be?

Yes
32 (78%)
No
9 (22%)

Total Members Voted: 41

Voting closed: 2019-12-25, 19:34:47

Author Topic: Looking for a cause of Interactive Rendering slowdown (+Poll)  (Read 6345 times)

2019-09-26, 20:34:47

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
Hello friends,

my name is Ondra (but not Ondra, the lead software developer :) ), I'm new Corona Renderer software developer.

First of all, I would like to express my deepest admiration for your work - visiting the forum's Gallery section and seeing the images you are creating provide true pleasure for the eyes :)

In part of our commitment to continually improve Corona rendering performance, we decided to deeply investigate the issue of Interactive Rendering slowdowns and / or freezes, that some users reported to us. The problem is, that we struggle to reproduce this slowdowns ourselves, so I decided to reach out to you, our dear users, to try to find some clues, which could help us to find the cause of these (potential) issues.

What would really help us is to find some specific cases and / or ideally 3DS Max scenes which manifest this issue, together with information in which version of Corona / Autodesk 3DS Max Interactive Rendering used to work fine (better / faster) and in which version it started to feel slower. If you don't have example scene but you know of some case when the slowdown occurs, please also feel free to write it here. Please describe it as specifically as possible, ideally mentioning version of Autodesk 3DS Max used, version of Corona Renderer, using / having installed additional plugins (and their versions), information about your OS and hardware.

Further if you experience any needless restarts of interactive rendering, or any information (or screen recordings etc.) which you think could be relevant, don't hesitate to mention it here :)

Also feel free to contact me with any additional feedback you'd like to share about your experience by sending me a message.

Thank you very much in advance for taking the time to provide us some clues - your feedback is invaluable, as at the moment, without ability to pinpoint some specific case, we really struggle to find the cause of this problem.

Have a nice day :)
Ondra

P.S. I am aware of the fact, that there are already some topics on this forums dedicated to this issue, but some of them are now really old and we are not sure if the problems mentioned there still persist. Therefore I decided to create this topic to get any relevant information under one roof. :)
« Last Edit: 2019-09-27, 00:43:08 by selene »

2019-09-28, 16:57:33
Reply #1

arqrenderz

  • Active Users
  • **
  • Posts: 705
  • arqrenderz.com
    • View Profile
    • arqrenderz
Hi selene, thx for the interest, IR is the most important tool for us, so yes i have a report of IR restarting with some forest, i have filled a bug report, the support ticket of the fresh desk is the #177229, developers say the manage to reproduce the bug but we havent heard of it since. its happening for us on almost every scene now, and the only solution for us is to hide this objects to work on the scene and unhide them and make a real render of it just to see how its looking (very time consmuing process, and if the ir is launched with the forest active we need to forece close the 3dsmax and loose the changes again)

thx again!

2019-09-30, 22:29:45
Reply #2

steyin

  • Active Users
  • **
  • Posts: 361
  • BALLS
    • View Profile
    • Instagram Page
I've noticed that as of late, any exports I get from coworkers from Rhino 5 (mainly OBJ) are creating long parsing times and slow IR at the beginning. It seems to balance off after a few mins, but I've never had the issue before. I'm running Max 2017 and Corona 4 HF1.

2019-10-01, 10:29:01
Reply #3

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
Hi selene, thx for the interest, IR is the most important tool for us, so yes i have a report of IR restarting with some forest, i have filled a bug report, the support ticket of the fresh desk is the #177229, developers say the manage to reproduce the bug but we havent heard of it since. its happening for us on almost every scene now, and the only solution for us is to hide this objects to work on the scene and unhide them and make a real render of it just to see how its looking (very time consmuing process, and if the ir is launched with the forest active we need to forece close the 3dsmax and loose the changes again)

thx again!

Hello Arqrenderz, thank you very much for your feedback. I'll have a look on the issue.

2019-10-01, 10:31:17
Reply #4

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
I've noticed that as of late, any exports I get from coworkers from Rhino 5 (mainly OBJ) are creating long parsing times and slow IR at the beginning. It seems to balance off after a few mins, but I've never had the issue before. I'm running Max 2017 and Corona 4 HF1.

Hello Steyin, thank you very much for your feedback. Please could you provide us such scene so we could investigate the cause of this issue?

You can use either our Private Uploader: https://corona-renderer.com/upload or you can send it to me as a private message. No uploaded files will be shared with anybody else or used for purposes other than debugging Corona without explicit permission.
« Last Edit: 2019-10-01, 10:35:08 by selene »

2019-10-01, 10:39:36
Reply #5

Designerman77

  • Active Users
  • **
  • Posts: 296
    • View Profile
Hey Ondra,

in C4D, iMac Pro 2018, OS High Sierra, I sometimes also experience Corona crashing after using IR.
Seems to happen in big scenes... not often... but two-three times it occured.

I´ll keep an eye on it... maybe there is a pattern in the cause.

Thanks for your constant optimization of Corona.

2019-10-01, 14:02:29
Reply #6

sprayer

  • Active Users
  • **
  • Posts: 715
    • View Profile
I am not notice IR slowdown only parsing time sometimes very long. I recently makes renders with particles with tyFlow, particles was not much ~100k(low poly spheres) and it start slowing parsing. I accidentally apply to particles light material and this was looks like freeze i don't wait more than 5m and start to investigate what it cause, but that's very much time for parsing only 100k spheres IMHO. Corona 4.1

2019-10-01, 14:25:27
Reply #7

romullus

  • Global Moderator
  • Active Users
  • ****
  • Posts: 6265
  • Let's move this topic, shall we?
    • View Profile
    • My Models
@sprayer, AFAIK when you assign lights to particles, then it brakes instancing of those lights. I think with 100K unique lights, you can expect very slow parsing.
I'm not Corona Team member. Everything i say, is my personal opinion only.
My Models | My Videos | My Pictures

2019-10-01, 15:30:36
Reply #8

sprayer

  • Active Users
  • **
  • Posts: 715
    • View Profile
Yes i was think about it, but without light material it is also add about ~5s for parsing scene what slowing response from IR

2019-10-01, 19:13:11
Reply #9

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
Hey Ondra,

in C4D, iMac Pro 2018, OS High Sierra, I sometimes also experience Corona crashing after using IR.
Seems to happen in big scenes... not often... but two-three times it occured.

I´ll keep an eye on it... maybe there is a pattern in the cause.

Thanks for your constant optimization of Corona.

Hello Designerman77, thank you very much for your feedback. If you would discover some case where the crashes are repeatedly occuring, please let us know and we will try to reproduce and investigate the problem. :)

2019-10-01, 20:07:49
Reply #10

Designerman77

  • Active Users
  • **
  • Posts: 296
    • View Profile
Hey Ondra,

in C4D, iMac Pro 2018, OS High Sierra, I sometimes also experience Corona crashing after using IR.
Seems to happen in big scenes... not often... but two-three times it occured.

I´ll keep an eye on it... maybe there is a pattern in the cause.

Thanks for your constant optimization of Corona.

Hello Designerman77, thank you very much for your feedback. If you would discover some case where the crashes are repeatedly occuring, please let us know and we will try to reproduce and investigate the problem. :)



You can bet that I will do that. :) I would also give you the scene.
Until now I could only notice that IR sometimes crashes, if I made a lot of changes in the scene very quickly - like every few seconds a change.

Regarding parsing time, I noticed that some scenes are simply parsing quicker than others.
Tried erasing parts of the scene... until it remained literally almost empty. Still the same long parsing...

In other scenes that are much bigger, parsing is much quicker...
Strange phenomenon that I had noticed also in previous Corona versions.

I´ll continue testing.

2019-10-02, 16:52:35
Reply #11

steyin

  • Active Users
  • **
  • Posts: 361
  • BALLS
    • View Profile
    • Instagram Page
Hello Steyin, thank you very much for your feedback. Please could you provide us such scene so we could investigate the cause of this issue?

You can use either our Private Uploader: https://corona-renderer.com/upload or you can send it to me as a private message. No uploaded files will be shared with anybody else or used for purposes other than debugging Corona without explicit permission.
I'll try to get you the scene along with a former one with a different Rhino export. The one I'm currently using might be heavier due to the modeling of the import...since its from the city of NY and who knows if they know what they're doing. I finally rendered the scene however for final renders and noticed the parsing times were only a few seconds compared to nearly 20-30 for IR.

2019-10-03, 10:29:59
Reply #12

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
Yes i was think about it, but without light material it is also add about ~5s for parsing scene what slowing response from IR

I asked about this issue my colleague and he agreed that in this case, the slowdown is currently expected, since as romullus mentioned:
Quote
when you assign lights to particles, then it breaks instancing of those lights
« Last Edit: 2019-10-03, 13:06:24 by selene »

2019-10-03, 10:37:30
Reply #13

selene

  • Corona Team
  • Active Users
  • ****
  • Posts: 13
    • View Profile
Hello Steyin, thank you very much for your feedback. Please could you provide us such scene so we could investigate the cause of this issue?

You can use either our Private Uploader: https://corona-renderer.com/upload or you can send it to me as a private message. No uploaded files will be shared with anybody else or used for purposes other than debugging Corona without explicit permission.
I'll try to get you the scene along with a former one with a different Rhino export. The one I'm currently using might be heavier due to the modeling of the import...since its from the city of NY and who knows if they know what they're doing. I finally rendered the scene however for final renders and noticed the parsing times were only a few seconds compared to nearly 20-30 for IR.

Steyin, the difference between parsing times for IR and final renders should definitely not be so big - there is certainly some problem (maybe on our side). If you could provide us the scene so we could have a look at it, it would help us a lot with finding the potential issues.
« Last Edit: 2019-10-03, 10:41:44 by selene »

2019-10-03, 10:41:51
Reply #14

Alexandre Besson

  • Active Users
  • **
  • Posts: 99
  • http://www.alexandre-besson.com
    • View Profile
    • Alexandre Besson portfolio
Forestpack and railclone (itoo software plugin for 3dsmax) slow down deeply the iR.