Author Topic: Visibility Track  (Read 1080 times)

2019-12-09, 15:54:44

SHORT CUTS

  • Active Users
  • **
  • Posts: 72
    • View Profile
    • SHORT CUTS
Hello,
is it a known problem that somehow corona doenst take the visibility track into account? I have an object which visibilty is animated, basically its set to 0 most of the time and then jumps to 1 in one frame. The problem is that the object is still visibile the whole time its set to 0...
Found a similar problem which was solved unfortunatly it had something to do with SSS and transculency which i dont use (index.php?topic=21309), its a rather simple material.

material of the object: http://prntscr.com/q8cw3a

screengrab of the curve editor and IR: http://prntscr.com/q8cthf

any pointers whats wrong?

2019-12-09, 16:16:08
Reply #1

SHORT CUTS

  • Active Users
  • **
  • Posts: 72
    • View Profile
    • SHORT CUTS
Found the problem...tried a simple object with the same material and it was working so it must have been something with the animated object. It was animated using a path deform using the stretch value and while it was set to 0 the object was still visible, setting it to 0.001 fixed it and the visibility track is now working as expected.

So dont use a value of 0 if you want to animate the visibility...

Sorry for the inital post, you can delete this whole thread if you want.

2019-12-11, 14:49:24
Reply #2

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9456
  • Marcin
    • View Profile
I'll just move it to resolved in case someone else has this problem.
It doesn't seem to be Corona-related, does it?

2019-12-13, 10:55:46
Reply #3

SHORT CUTS

  • Active Users
  • **
  • Posts: 72
    • View Profile
    • SHORT CUTS
Doesnt happen with vray so i would guess it has something to do with corona.

corona: http://prntscr.com/qa9nfn
vray: http://prntscr.com/qa9ntt