Author Topic: Viewport slows down lot after setting proxy´s path from absolute to relative.  (Read 1875 times)

2020-01-26, 14:12:14

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hello guys,

I work on 2 Computers who have different sdd structure and cannot use therefor absolute file paths to work on same scene. This is no problem since Corona can look into Cinema's asset paths and thus use relative file names. How ever when I set bunch of Proxies from absolute to relative path the viewport slows down to cca. 3 fps. Going back to absolute paths, viewport speed is normal again. Could you try to reproduce this problem? If not I can make screen video for demonstration.

cheers,
Daniel

2020-01-27, 14:44:24
Reply #1

metopa

  • Corona Team
  • Active Users
  • ****
  • Posts: 28
    • View Profile
Hi Daniel,

does the slowdown happen only during the proxy reloading or all the time?

Cheers,
Slava

2020-01-28, 16:38:17
Reply #2

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hi, all the time unfortunately, until I use current computers absolute file path, then it disappears. I will make a screen recording when I have more time.
« Last Edit: 2020-01-28, 16:46:50 by Daniel Mikolajčák »

2020-01-29, 11:26:22
Reply #3

metopa

  • Corona Team
  • Active Users
  • ****
  • Posts: 28
    • View Profile
Thank you, screen recording will help a lot.

Does it happen with a particular scene/Proxy file only?

Also is it possible for you to share the scene and the proxies or at least part of them that we can use to reproduce the issue?
If you don't want to share it publicly, you can use our private uploader: https://corona-renderer.com/upload


Cheers,
Slava

2020-01-29, 20:23:29
Reply #4

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hello Slava,
thank you for taking up this problem. I have uploaded the video to youtube:

I have tried other heavy poly proxies too. It happens as well so it seem it is not related to one specific model.

I have also uploaded scene along with a proxy.
1580325859_Archive.zip

2020-01-30, 15:24:38
Reply #5

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1652
  • Bengamin
    • View Profile
    • Cormats
Hi Daniel,

Thanks for the scene file and video. It is currently being added to our internal bug reports for further testing. Could you also supply your Cinema, Corona version's and what OS you are running? Update, just found these details of yours, are they still current?

System:
Corona 5 RC2
Cinema 4D R21
Mac Os Catalina 10.15.1

Thanks in advance.

2020-01-30, 15:28:05
Reply #6

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1652
  • Bengamin
    • View Profile
    • Cormats

2020-01-30, 18:25:04
Reply #7

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile

2020-02-10, 11:51:02
Reply #8

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1652
  • Bengamin
    • View Profile
    • Cormats
Hi Daniel, We have tried and tried but cannot reproduce this "slowly down issue" once the paths are modified. Are you still experiencing this issue? Is it for any proxy scene or just this one?

2020-02-10, 11:57:22
Reply #9

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hello,
it happened in any scene with any proxy, granted more complex the proxy was and more of them were in the scene the more significant slowdown was. I will look at it again to see if there is some dependency on object. Are you able to try it on Mac?

2020-02-10, 12:17:02
Reply #10

metopa

  • Corona Team
  • Active Users
  • ****
  • Posts: 28
    • View Profile
Hi Daniel,

yes, I've tried it on Mac Catalina and no repro as well :(
It would be very helpful if you can try to repro it with Corona4D V4, as Proxies were rewritten in V5.
You can download V4 here https://corona-renderer.com/download/old-cinema-4d

Cheers,
Slava

2020-02-13, 17:17:17
Reply #11

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hello, I have uploaded Proxy Problem.zip via private uploader. One more time a sample scene and screen recording.

V4 shows same slowdown.

Slowdown depends on how many proxies are effected. 2 relative proxies slow down viewport to 13 fps while 9 to 2 fps.

Hiding proxies does not solve anything only relinking to absolute path or deleting.

hope this helps the investigations.

2020-05-29, 15:41:45
Reply #12

Daniel Mikolajčák

  • Active Users
  • **
  • Posts: 55
    • View Profile
Hello guys, I have tried latest v.6 daily build and am glad to say that problem I reported here has been fixed.
Thank you
Daniel

2020-06-02, 12:29:48
Reply #13

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1652
  • Bengamin
    • View Profile
    • Cormats
Hi, thank you for the update. That's pleasing to hear. As always, if it arises again or any other issue, please let us know. :)