Author Topic: Fog not reflecting in the window  (Read 1009 times)

2020-02-06, 11:44:04

zbieraj

  • Active Users
  • **
  • Posts: 104
    • View Profile
Hi,

Why does the fog not appear in the reflection of the window?

2020-02-06, 14:02:14
Reply #1

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3096
    • View Profile
We'd need some info on the scene set up, such as what the fog is (global? applied to a cube? If a cube, where does the geometry for that cube stop in relation to the window? CoronaVolume material? Some other material?)

In general whenever asking "Why does my one image look like this", we will need some description of the scene set up, grabs that show that set up and materials, and so on.

2020-02-06, 20:31:30
Reply #2

zbieraj

  • Active Users
  • **
  • Posts: 104
    • View Profile
Corona Volume Material is applied to cube-ish geometry. In ends just before the windows. Global fog is turned off.

2020-02-06, 20:43:38
Reply #3

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3096
    • View Profile
So long as the geometry with the Volume Material on it is not intersecting the window, this should work (and does in my tests. Best thing I can suggest as a result is to send us the scene, see https://help.c4d.corona-renderer.com/support/solutions/articles/12000033461-how-to-report-issues-c4d for the private uploader etc.

2020-02-06, 20:44:39
Reply #4

TomG

  • Corona Team
  • Active Users
  • ****
  • Posts: 3096
    • View Profile
Don't forget to let us know which version of Corona, which version of Cinema, which OS and version of OS. Thanks!

2020-02-07, 10:26:14
Reply #5

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1603
  • Bengamin
    • View Profile
    • Cormats
I've also done a quick test and it is working for me. Here's my rough setup.






2020-02-07, 11:01:04
Reply #6

beanzvision

  • Corona Team
  • Active Users
  • ****
  • Posts: 1603
  • Bengamin
    • View Profile
    • Cormats
Another thing we noticed with your scene is that the decking reflection doesn't match the physical one. It looks compressed or distorted. Setting the phong angle to 0 should fix this.


2020-02-07, 17:50:01
Reply #7

zbieraj

  • Active Users
  • **
  • Posts: 104
    • View Profile
Thanks! It was actually the windows being inside of the fog volume -.-. Because I had the preview of the windows turned on, I followed if the fog is in front of the columns which are behind the windows. So I thought that the volume is in front of the windows but it was not... Oh me :/.