Author Topic: .step files into 3d Max HEEEEEELP  (Read 15088 times)

2015-03-24, 14:51:08
Reply #15

Gabriel Sumner

  • Active Users
  • **
  • Posts: 12
    • View Profile
Hi GestaltDesign,

thanks for the info, and for the link to your thread :)!
I guess I'll just stick around with the Alpha 0.6 for this particular project, and hope that Ondra will be able to resolve the issue in future versions. Up till now neither do I process the STEP / IGES files myself, nor do i have any influence at what kind of data is being delivered, very unfortunate. But good to know the issue is known!

Thanks a lot again, and thank you Ondra for doing the incredible job out there :)

CheerZzz,
G.S.

2015-03-24, 17:03:58
Reply #16

Goran Gajic

  • Active Users
  • **
  • Posts: 11
    • View Profile
Npower is best of all I tested, sometimes you have to clean manually some "balls", they appear mostly because of CAD designer who didn't close or connect nurbs properly..
Sometimes SAT format understand better "unfinished" nurbs...

2015-05-21, 16:41:23
Reply #17

Monster0605

  • Active Users
  • **
  • Posts: 19
    • View Profile
Hi guys, I have the same problem here, Bild left is Vray Rendering and the right one is Corona.
I have imported the mash over nPower importer from one STEP Data Format.  Like my next step to resolve the problem I have repair my STEP mash with Transmagic CAD Repair Tool but that doesn’t  help me with my problem. Ondra please repair that, I love Corona , but without one clean tessellation solution I can not use it in my daily Job.

2015-05-21, 17:14:55
Reply #18

GestaltDesign

  • Active Users
  • **
  • Posts: 64
    • View Profile
Hi Monster,

The solution is to use Rhino and export geometry as .obj using the detailed mesh control option.
In the detailed mesh options you can limit edge length.
Limit the edge length (baring in mind relative object scale) and test using the preview option to eliminate long, elongated polygons which are the culprits.
Bare in mind the default 0 edge length means it is deactivated and allowing the potential for elongated polys.
Since using this approach and getting to know the mesh settings controls I have eliminated a whole host of import issues in Max.
Optimised obj meshes will also massively reduce file sizes in comparison to body objects, so win win.

2015-05-25, 15:48:50
Reply #19

maru

  • Corona Team
  • Active Users
  • ****
  • Posts: 9057
  • Marcin
    • View Profile

2015-05-25, 22:35:47
Reply #20

Monster0605

  • Active Users
  • **
  • Posts: 19
    • View Profile
Yes, no problem.